Project

General

Profile

Bug #8933

diagnostics -> backup/restore -> reinstall packages hangs

Added by Florian Apolloner over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
Package System
Target version:
Start date:
09/24/2018
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.4.4
Affected Architecture:
All

Description

Trying to reinstall all system packages via diagnostic hangs at "Please wait while the update system initializes" in the package manager. Is there any log output somewhere to see if it is stuck? Or any process that should be running; or is that functionality just broken?

History

#1 Updated by Jim Pingle over 2 years ago

  • Target version set to 2.4.4-GS
  • Affected Architecture All added
  • Affected Architecture deleted ()

I can reproduce this here on a couple different systems. I don't see any sign of pkg running or any log entries suggesting it's started the process.

#2 Updated by Steve Beaver over 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Steve Beaver

#3 Updated by Steve Beaver over 2 years ago

  • Status changed from In Progress to Feedback
  • Assignee changed from Steve Beaver to Renato Botelho

Fixed in updater version 0.54

#4 Updated by Florian Apolloner over 2 years ago

How should I test this?

#5 Updated by Steve Wheeler over 2 years ago

You can test this in a 2.4.5 snapshot. Just choose the development branch in Update Settings.

However I was not able to replicate this in 2.4.4.
What packages did you have installed? What architecture were you testing in?

#6 Updated by Jim Pingle over 2 years ago

Nothing unusual on the boxes where I could reproduce this. Common things like ACME, nmap, OpenVPN client export, sudo, system patches.

#7 Updated by Florian Apolloner over 2 years ago

I have acme, Cron, haproxy, Netgate_Coreboot_Upgrade and openvpn client export installed. Can you link me the patch? I rather not update to a snapshot.

#8 Updated by Renato Botelho over 2 years ago

Florian Apolloner wrote:

I have acme, Cron, haproxy, Netgate_Coreboot_Upgrade and openvpn client export installed. Can you link me the patch? I rather not update to a snapshot.

Just make sure you have pfSense-upgrade version 0.54 or newer. You can check that on console running `pkg info pfSense-upgrade`. If you are running an older version just run `pkg upgrade pfSense-upgrade`

#9 Updated by Renato Botelho over 2 years ago

Steve Wheeler wrote:

You can test this in a 2.4.5 snapshot. Just choose the development branch in Update Settings.

However I was not able to replicate this in 2.4.4.
What packages did you have installed? What architecture were you testing in?

Fix was pushed to 2.4.4 as well, it's on pfSense-upgrade 0.54 or newer

#10 Updated by Steve Beaver over 2 years ago

  • Target version changed from 2.4.4-GS to 2.4.4-p1

#11 Updated by Steve Beaver over 2 years ago

  • Target version changed from 2.4.4-p1 to 2.4.4-GS

#12 Updated by Jim Pingle over 2 years ago

  • Status changed from Feedback to Resolved

Works now

Also available in: Atom PDF