Project

General

Profile

Feature #9285

Add an option to disable the ping-check in dhcpd

Added by Arthur Wiebe 12 months ago. Updated 28 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DHCP Server
Target version:
Start date:
01/22/2019
Due date:
% Done:

100%

Estimated time:

Description

In experiencing some strange DHCP behavior at a customer site, where DHCP leases were getting abandoned and never re-used causing the pool to fill up and run out of available IPs, the solution was to turn off the ping-check in dhcpd.conf.
The problem is that currently in pfSense that conf option is hard-coded and there is no way to override it.

I've created a patch to test it with the site, where it's not working. I'll submit a pull request for your consideration.

Associated revisions

Revision 5197e3e3 (diff)
Added by Renato Botelho 4 months ago

Fix #9285: Move ping-check option from global to per-subnet

Revision 9133e01d (diff)
Added by Renato Botelho 4 months ago

Fix #9285: Move ping-check option from global to per-subnet

(cherry picked from commit 5197e3e3a3b0ee048785e2ffb4222d7cba4e6c74)

Revision 96701431 (diff)
Added by Renato Botelho 29 days ago

Fix #9285: Move ping-check option from global to per-subnet

(cherry picked from commit 5197e3e3a3b0ee048785e2ffb4222d7cba4e6c74)

History

#1 Updated by Renato Botelho 8 months ago

  • Status changed from New to Feedback
  • Assignee set to Renato Botelho
  • Target version set to 2.5.0
  • % Done changed from 0 to 100

PR has been merged. Thanks!

#2 Updated by Chris Linstruth 5 months ago

This looks like it should be added on a per-subnet basis instead of globally. As this patch stands right now if you disable ping check on an earlier subnet and it is unchecked in a later subnet, you still get a global ping-check true; in the dhcpd.conf file.

#3 Updated by Jim Pingle 5 months ago

  • Status changed from Feedback to New

#4 Updated by Renato Botelho 4 months ago

  • Status changed from New to Feedback

#5 Updated by Viktor Gurov 3 months ago

Renato Botelho wrote:

Applied in changeset 5197e3e3a3b0ee048785e2ffb4222d7cba4e6c74.

Tested on 2.5.0.a.20191011.1853

# grep ping /var/dhcpd/etc/dhcpd.conf:
        ping-check false;

Resolved

#6 Updated by Jim Pingle 3 months ago

  • Status changed from Feedback to Resolved

#7 Updated by Jim Pingle about 2 months ago

  • Target version changed from 2.5.0 to 2.4.5

#8 Updated by Jim Pingle about 1 month ago

  • Status changed from Resolved to Feedback

Needs checked and/or tested again on 2.4.5 snapshots

#9 Updated by Jim Pingle 29 days ago

  • Status changed from Feedback to In Progress
  • Assignee changed from Renato Botelho to Jim Pingle

It looks like the main part of this PR was not picked back, only a later commit

PR link: https://github.com/pfsense/pfsense/pull/4043

#11 Updated by Jim Pingle 28 days ago

  • Status changed from Feedback to Resolved

Option is now present in the GUI and appears to work as expected on a per-subnet basis.

2.4.5.a.20191220.0501

Also available in: Atom PDF