Project

General

Profile

Bug #9359

diag_tables.php duplicate entries from webConfigurator lockout table

Added by Joshua Sign 10 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
02/28/2019
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4_2
Affected Architecture:
All

Description

Entries in the webConfigurator Lockout Table are always listed, whatever the table you select.

Possible fix should be :
- add :

unset($entries);
after line 61 in /etc/inc/auth.inc
- add :
$entries=array();
after line 78 in /usr/local/www/diag_tables.php to avoid delete of these unwanted entries
- add :
$entries=array();
before line 120 in /usr/local/www/diag_tables.php

Associated revisions

Revision 9146639e (diff)
Added by Jim Pingle 9 months ago

Initialized entries variable before use. Fixes #9359

Revision b69eea46 (diff)
Added by Jim Pingle 9 months ago

Initialized entries variable before use. Fixes #9359

(cherry picked from commit 9146639e722b4d437d19b5ade1157ae01849a313)

History

#1 Updated by Jim Pingle 9 months ago

  • Category set to Web Interface
  • Assignee set to Jim Pingle
  • Target version set to 2.5.0
  • Affected Architecture set to All

I can't reproduce this as stated, but I can see how it might happen since the variable is used without being initialized. I'm testing on PHP 7.3 which may handle that better than 7.2.

#2 Updated by Jim Pingle 9 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#3 Updated by Jim Pingle 7 months ago

  • Target version changed from 2.5.0 to 2.4.4-p3

#4 Updated by Chris Linstruth 7 months ago

2.4.4-p3 looks good

Tested against sshguard table since webConfiguratorlockout table has been deprecated by #9223 and replaced by sshguard.

Additions to sshguard are only shown when viewing that table, not any other tables.

#5 Updated by Jim Pingle 7 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF