Project

General

Profile

Actions

Bug #9506

closed

Dynamic DNS update notification sent even if IP address didn't change

Added by robi robi about 3 years ago. Updated 11 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Dynamic DNS
Target version:
-
Start date:
05/07/2019
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.5-p1
Affected Architecture:

Description

pfSense sends Dynamic DNS update notifications even in the cases when IP address doesn't change.
For some reason, the client needs to update the Dynamic DNS entry on the server even when the actual IP address doesn't change. Typical case when using a PPPoE line, and the ISP forces a re-connection of the PPPoE link, but hands out the same IP address as before.
The updater triggers an update of the address, but also sends a notification that it has been updated. To the same address as above.

I'd suggest to either:
- add an option to skip notification in cases like this
- make the notification text more comprehensive to reflect the earlier IP address (like "DynDNS updated IP Address on WAN2 (igb0) from 4.5.6.7 to 1.2.3.4" in case of a real change, and "DynDNS updated IP Address on WAN2 (igb0) from 1.2.3.4 to 1.2.3.4 (no change)"
- maybe examine why Dynamic DNS update is triggered when the address remains the same, perhaps the service policy (noip?) needs regular updates even when addresses don't change?


Related issues

Is duplicate of Bug #12610: Dynamic DNS services are restarted at every rc.newwanip event, regardless of whether the IP is changed or notDuplicateViktor Gurov

Actions
Actions #1

Updated by Jim Pingle almost 3 years ago

  • Category set to Dynamic DNS
Actions #2

Updated by Jeremy  99 over 1 year ago

I also have this same problem with 2.4.4-RELEASE-p2. I see other people have reported this issue over the years too:

2015
https://forum.netgate.com/topic/83920/pfsense-notifies-me-dyndns-updated-ip-but-it-didn-t

2019
https://forum.netgate.com/topic/145316/dyndns-update-emails-when-the-ip-doesn-t-change

I wonder why this issue isn't listed on the roadmap so it can get fixed. I like all 3 suggestions from the ticket creator, robi, especially the one about the email mentioning both the previous IP and the new IP. Thank you all.

Actions #4

Updated by Viktor Gurov 11 days ago

  • Is duplicate of Bug #12610: Dynamic DNS services are restarted at every rc.newwanip event, regardless of whether the IP is changed or not added
Actions #5

Updated by Viktor Gurov 11 days ago

  • Status changed from New to Duplicate

Duplicate of #9506

Actions

Also available in: Atom PDF