Project

General

Profile

Bug #960

Problem with config sync + ipsec + special characters

Added by Thiago Witt over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
CARP
Target version:
Start date:
10/20/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

When the description field in ipsec's phases 1 and 2 contains special characters such as accentuation config sync is unable to sync to slave.

E.G. I had a phase2 that was causing problems by having a 'ã' in the description. In the master XML it was translated to the correct html entity (ã) but it wouldn't sync over to the slave until I removed it.

Associated revisions

Revision 26732357 (diff)
Added by Pierre POMES over 8 years ago

Ticket #960. Use XMLRPC automatic base64 encoding for strings (XML_RPC_auto_base64)

History

#1 Updated by Jim Pingle over 8 years ago

We escape that with CDATA in the config, though I'm not sure how well that translates via XMLRPC (pfsync and CARP really don't have anything to do with config sync, that's XMLRPC). I know in some cases the special characters were blanked out when moving over. I thought the CDATA protected fields transferred correctly though.

#2 Updated by Chris Buechler over 8 years ago

  • Subject changed from Problem with pfsync + ipsec + special characters to Problem with config sync + ipsec + special characters

#3 Updated by Pierre POMES over 8 years ago

Hi,

This also happens for other descriptions, I tested for a carp VIP description and the problem is the same (also escaped in a CDATA)

Code 109: XML error: Invalid character at line XXX

Pierre

#4 Updated by Pierre POMES over 8 years ago

Other information:

1) In the GUI, I used "CARP LAN éé" as description

2) config.xml shows :

<descr><![CDATA[CARP LAN &eacute;&eacute;]]></descr>

3) A network capture during a XMLRPC sync :

00002220  0a 3c 76 61 6c 75 65 3e  3c 73 74 72 69 6e 67 3e .<value> <string>
00002230  43 41 52 50 20 4c 41 4e  20 e9 e9 3c 2f 73 74 72 CARP LAN  ..</str

#5 Updated by Pierre POMES over 8 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Hi Thiago,

This problem should be solved now. Can you try again ?

Thanks !

Pierre

#6 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF