Project

General

Profile

Bug #965

IPSec configuration network selection doesn't match rest of UI

Added by Adam Thompson over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
IPsec
Target version:
Start date:
10/21/2010
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

Related to Feature Request #946, but not quite the same...

Everywhere else in the 2.0 UI (mostly rules, but I think I've seen it elsewhere), where I'm required to select any/host/network/etc. the drop-down includes "LAN address", "LAN subnet", "WAN address", "WAN subnet", etc. and the "LAN" and "WAN" names are automatically updated to reflect renamed interfaces.

When configuring IPSec Phase 2 SAs, the option is merely "LAN subnet" or "network". The first problem is that "LAN subnet" is meaningless if you've renamed your LAN interface and can't remember which one was the original "LAN"; the obvious enhancement would be to allow "LAN subnet", "OPT1 subnet", "OPT2 subnet", etc. (as well as allowing aliases, per Jim's Feature Request). That leads to the further enhancement that LAN/OPT1/etc should be replaced with the actual i/f names.

Other than that, IPSec is working great :-).

Associated revisions

Revision d48dbceb (diff)
Added by Erik Fonnesbeck over 8 years ago

Add other interfaces to local network selection and show proper names. Fixes #965

History

#1 Updated by Erik Fonnesbeck over 8 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#2 Updated by David Szpunar over 8 years ago

Confirmed that I've seen this fix in action when heavily configuring several IPsec VPN (site-to-site and Mobile) configurations over the past few weeks since this bug was marked as Feedback, and I remember the old way before, definitely improved and I haven't run into any issues with it.

#3 Updated by Chris Buechler over 8 years ago

  • Status changed from Feedback to Resolved

thanks

Also available in: Atom PDF