Project

General

Profile

Actions

Bug #10524

closed

Bridge that includes a GIF interface does not come up at boot

Added by Yuran Yastreb over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Category:
Interfaces
Target version:
Start date:
05/03/2020
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.5
Affected Architecture:

Description

I use pfsense version 2.4.5. This problem occurs when a gif port is added to the bridge. This bridge does not rise after the system is restarted, but bridge works correctly without gif port. I tried creating gif port as opt1 and bridge as opt2 and vice versa.
The following entries are present in the logs:

rc.bootup: The command '/usr/sbin/arp -d -i 'bridge0' -a > /dev/null 2>&1 ' returned exit code '1', the output was ''
rc.bootup: The command '/sbin/ifconfig 'bridge0' -staticarp ' returned exit code '1', the output was 'ifconfig: interface bridge0 does not exist'

Actions #1

Updated by Jim Pingle over 1 year ago

  • Subject changed from the bridge that includes the gif port does not rise after reboot to Bridge that includes a GIF interface does not come up at boot
  • Category set to Interfaces
  • Affected Version set to 2.4.5

Did this work on a previous version?

Actions #2

Updated by Yuran Yastreb over 1 year ago

Jim Pingle wrote:

Did this work on a previous version?

I didn't use this combination in previous version. However, there is indirect evidence that this problem was present in previous versions: https://forum.netgate.com/topic/113534/bridge-and-gif-tunnel
Another clarification: it is enough to perform some manipulation with the bridge in webgui and save it, after which the bridge rises.

Actions #4

Updated by Jim Pingle over 1 year ago

  • Status changed from New to Pull Request Review
Actions #5

Updated by Renato Botelho over 1 year ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Renato Botelho
  • Target version set to 2.5.0
  • % Done changed from 0 to 100

PR has been merged. Thanks!

Actions #6

Updated by Danilo Zrenjanin about 1 year ago

  • Status changed from Feedback to Resolved

I was able to reproduce the bug on 2.4.5-p1

Retested on:
2.5.0-DEVELOPMENT (amd64)
built on Thu Sep 03 19:02:32 EDT 2020
FreeBSD 12.2-PRERELEASE

The Bridge interface containing (OPT, GIF) goes up without any snags after reboot.

I am resolving the ticket.

Actions

Also available in: Atom PDF