Project

General

Profile

Actions

Bug #11296

open

Static route targets may still reachable via default route when the gateway they should route through is down

Added by Viktor Gurov about 2 years ago. Updated 3 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Routing
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Plus-Next
Release Notes:
Default
Affected Version:
2.4.5-p1
Affected Architecture:

Description

https://forum.netgate.com/topic/160103/static-routes-not-as-expected:
When WAN gateway is down, I can still access/ping stuff that is set "static route" thru the primary WAN.

`/etc/rc.gateway_alarm` must delete static routes entries for that gateway

same issue on 2.5.0.a.20210121.2350
see also #9969 #10001


Related issues

Related to Regression #11986: Static routes may not be in routing table when expectedResolved06/02/2021

Actions
Actions #2

Updated by Jim Pingle about 2 years ago

  • Status changed from New to Pull Request Review
  • Target version set to CE-Next
Actions #3

Updated by Renato Botelho almost 2 years ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Viktor Gurov

PR has been merged. Thanks!

Actions #4

Updated by Viktor Gurov almost 2 years ago

  • % Done changed from 0 to 100
Actions #5

Updated by Alhusein Zawi almost 2 years ago

  • Status changed from Feedback to Resolved

Fixed.

If WAN GW is down I cannot ping even if there was static route.

2.5.0-RELEASE (amd64)
built on Tue Feb 16 08:56:29 EST 2021
FreeBSD 12.2-STABLE

Actions #6

Updated by Jim Pingle almost 2 years ago

  • Target version changed from CE-Next to 2.6.0
Actions #7

Updated by Jim Pingle over 1 year ago

  • Plus Target Version set to 21.05

Already present on 21.05 builds.

Actions #8

Updated by Jim Pingle over 1 year ago

  • Subject changed from When WAN gateway is down, I can still access/ping stuff that is set "static route" thru the primary WAN to Static route targets may still reachable via default route when the gateway they should route through is down

Updating subject for release notes.

Actions #9

Updated by Jim Pingle over 1 year ago

  • Target version changed from 2.6.0 to 2.5.2
Actions #10

Updated by Jim Pingle over 1 year ago

  • Status changed from Resolved to New
  • Target version changed from 2.5.2 to 2.6.0
  • Plus Target Version changed from 21.05 to 21.09

Per Jim T, reverted this from 2.6.0 and 2.5.2. It appears to be causing some unintended side effects.

Can revisit a different approach, or perhaps making it optional and off by default, for the next release.

Actions #11

Updated by Jim Pingle over 1 year ago

  • Status changed from New to Feedback
Actions #12

Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to New
Actions #13

Updated by Jim Pingle over 1 year ago

  • Related to Regression #11986: Static routes may not be in routing table when expected added
Actions #14

Updated by Jim Pingle over 1 year ago

  • Plus Target Version changed from 21.09 to 22.01

Moving ahead, too close to release to make another attempt at this and have enough time to validate the change in behavior.

Actions #15

Updated by Jim Pingle over 1 year ago

  • Plus Target Version changed from 22.01 to 22.05
Actions #16

Updated by Jim Pingle over 1 year ago

  • Target version changed from 2.6.0 to CE-Next
Actions #17

Updated by Alhusein Zawi about 1 year ago

Static route is still reachable while WAN gateway is Marked Gateway as Down.

22.01.a.20211120.0600

Actions #18

Updated by Jocelyn Viau about 1 year ago

Thank you for reporting this issue, I have a very similar problem. In my case, I added a static route that goes through a routed IPSec tunnel (VTI). When the tunnel goes down, the traffic for that static route still tries to go through the tunnel and get lost. When the tunnel is down or the IPSec VTI gateway is unreacheable, I would like the static route that uses the VTI Gateway to be removed from the routing table and have the traffic be routed using the remaining routing table.

Actions #19

Updated by Jim Pingle 9 months ago

  • Plus Target Version changed from 22.05 to 22.09
Actions #20

Updated by Jim Pingle 7 months ago

  • Plus Target Version changed from 22.09 to 22.11
Actions #21

Updated by Jim Pingle 4 months ago

  • Plus Target Version changed from 22.11 to 23.01
Actions #22

Updated by Jim Pingle 3 months ago

  • Assignee deleted (Viktor Gurov)
Actions #23

Updated by Jim Pingle 3 months ago

  • Start date deleted (01/23/2021)
  • % Done changed from 100 to 0
  • Plus Target Version changed from 23.01 to Plus-Next

While this can be confusing, any solution tried thus far has broken more than it has fixed. If someone wants to pick it up and try we can look at proposed solutions, but for now there isn't a compelling reason to keep it on a specific target.

Actions

Also available in: Atom PDF