Project

General

Profile

Bug #11361

ISO Installer not functioning on latest snapshots

Added by Jim Pingle 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Urgent
Category:
Installer
Target version:
Start date:
02/02/2021
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.5.0
Affected Architecture:
Release Notes:
Default

Description

The installer ISO is not functioning on the latest 2.5.0 snapshots. More information in the forum thread at https://forum.netgate.com/topic/160469/2-5-0-nightly-iso-install-broken

Reports indicate that attempting to accept the license restarts the installer and the user can't progress past the license screen.

Also the name of the ISO file has changed from being named pfSense-CE-<blah>.iso to pfSense-CE-iso-<blah>.img, but upon renaming the .img file to .iso it can still be used as an ISO.

Assigning to Luiz since he is looking into the name change part first.

History

#1 Updated by Manuel Piovan 2 months ago

i can barely see, when i press enter,

/etc/rc.local: bsdinstall: not found

latest iso is only 175MB

#2 Updated by Michael Spears 2 months ago

Manuel Piovan wrote:

i can barely see, when i press enter,

/etc/rc.local: bsdinstall: not found

latest iso is only 175MB

Jim Pingle wrote:

The installer ISO is not functioning on the latest 2.5.0 snapshots. More information in the forum thread at https://forum.netgate.com/topic/160469/2-5-0-nightly-iso-install-broken

Reports indicate that attempting to accept the license restarts the installer and the user can't progress past the license screen.

Also the name of the ISO file has changed from being named pfSense-CE-<blah>.iso to pfSense-CE-iso-<blah>.img, but upon renaming the .img file to .iso it can still be used as an ISO.

Assigning to Luiz since he is looking into the name change part first.

Seeing the same on the memstick installer (unable to go past the license screen)

#3 Updated by Renato Botelho 2 months ago

  • Status changed from New to Feedback
  • Assignee changed from Luiz Souza to Renato Botelho

Fixed

#4 Updated by Danilo Zrenjanin 2 months ago

Tested on the latest release (pfSense-CE-2.5.0-DEVELOPMENT-amd64-latest.iso)

I still can't pass the Copyright and distribution notice. Please check.

#5 Updated by Renato Botelho 2 months ago

Danilo Zrenjanin wrote:

Tested on the latest release (pfSense-CE-2.5.0-DEVELOPMENT-amd64-latest.iso)

I still can't pass the Copyright and distribution notice. Please check.

Fix will be available on next round of snapshots

#6 Updated by yon Liu 2 months ago

Jim Pingle Do you get the same behavior with the memstick?

yes. i am using memstick, it still can't work.

only the version work. pfSense-CE-memstick-2.5.0-DEVELOPMENT-amd64-20210126-2350.img

#7 Updated by Renato Botelho 2 months ago

yon Liu wrote:

Jim Pingle Do you get the same behavior with the memstick?

yes. i am using memstick, it still can't work.

only the version work. pfSense-CE-memstick-2.5.0-DEVELOPMENT-amd64-20210126-2350.img

I've tested pfSense-CE-2.5.0-DEVELOPMENT-amd64-20210203-2250.iso and it worked.

#8 Updated by Renato Botelho 2 months ago

  • Status changed from Feedback to Resolved

memstick is also working

#9 Updated by Danilo Zrenjanin 2 months ago

I can confirm. The latest release works fine. Thank you.

#10 Updated by Jim Pingle 2 months ago

Adding another data point, the latest snapshot installs as expected.

Also available in: Atom PDF