Project

General

Profile

Actions

Bug #13564

closed

pfSense - Feature #13446: Upgrade PHP from 7.4 to 8.1

PHP error after creating a Route Map

Added by Danilo Zrenjanin 4 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
FRR
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.01
Affected Version:
2.7.0
Affected Plus Version:
Affected Architecture:

Description

Crash report begins.  Anonymous machine information:

amd64
14.0-CURRENT
FreeBSD 14.0-CURRENT #0 devel-main-n255799-28f6f5e488e: Fri Oct 14 06:28:01 UTC 2022     root@freebsd:/var/jenkins/workspace/pfSense-CE-snapshots-master-main/obj/amd64/5sNqxS3O/var/jenkins/workspace/pfSense-CE-snapshots-master-main/sources/FreeBSD-src-dev

Crash report details:

PHP Errors:
[15-Oct-2022 09:52:22 Etc/UTC] PHP Fatal error:  Uncaught TypeError: Cannot access offset of type string on string in /usr/local/www/pkg.php:484
Stack trace:
#0 {main}
  thrown in /usr/local/www/pkg.php on line 484

No FreeBSD crash data found.

Files

PHP_errors (1).log (215 Bytes) PHP_errors (1).log Danilo Zrenjanin, 10/15/2022 05:00 AM

Related issues

Is duplicate of Bug #13642: PHP Error: frr_zebra.inc:159ResolvedReid Linnemann

Actions
Actions #1

Updated by Danilo Zrenjanin 4 months ago

  • Subject changed from PHP error after creating a Route Map in /pkg.php?xml=frr/frr_global_routemaps.xml to PHP error after creating a Route Map
Actions #2

Updated by Kris Phillips 4 months ago

  • Status changed from New to Confirmed

I can confirm this bug report. Creating an empty Route Map produces this error even when not settings are applied.

Actions #3

Updated by Jim Pingle 3 months ago

  • Parent task set to #13446
Actions #4

Updated by Reid Linnemann about 2 months ago

  • Status changed from Confirmed to Feedback
  • Assignee set to Reid Linnemann

I believe this is fixed by the resolution for #13642. Can you retest?

Actions #5

Updated by Jim Pingle about 2 months ago

  • Status changed from Feedback to New

I still get errors here:

PHP ERROR: Type: 1, File: /usr/local/pkg/frr/inc/frr_zebra.inc, Line: 418, Message: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/pkg/frr/inc/frr_zebra.inc:418
Stack trace:
#0 /usr/local/pkg/frr/inc/frr_zebra.inc(821): frr_zebra_generate_routemaps()
#1 /usr/local/pkg/frr.inc(669): frr_generate_config_zebra()
#2 /etc/inc/pkg-utils.inc(707) : eval()'d code(1): frr_generate_config()
#3 /etc/inc/pkg-utils.inc(707): eval()
#4 /etc/rc.start_packages(66): sync_package('FRR')
#5 {main}
thrown @ 2022-12-08 11:15:24
Actions #6

Updated by Reid Linnemann about 2 months ago

I neglected to tick the portrevision when I fixed this in #13642, I have corrected that and the next build should have the corrected code for sorting routemaps.

Actions #7

Updated by Reid Linnemann about 2 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #8

Updated by Reid Linnemann about 2 months ago

  • Is duplicate of Bug #13642: PHP Error: frr_zebra.inc:159 added
Actions #9

Updated by Reid Linnemann about 2 months ago

The above commit adds a workaround if the user's config.xml already has empty config tags in the frrglobalroutemaps tag.

Actions #10

Updated by Jim Pingle about 2 months ago

  • Status changed from Feedback to Resolved

This appears to be OK on a current snap with the latest package (After removing some leftover debug prints in the base).

It cleaned up the bad tag and I can also list and create route map entries.

Actions

Also available in: Atom PDF