Project

General

Profile

Actions

Bug #13642

closed

pfSense - Feature #13446: Upgrade PHP from 7.4 to 8.1

PHP Error: frr_zebra.inc:159

Added by Steve Wheeler 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Category:
FRR
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.01
Affected Version:
Affected Plus Version:
23.01
Affected Architecture:
All

Description

This prevented boot completing. I had to uninstall FRR at the CLI.

Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/pkg/frr/inc/frr_zebra.inc:159
23.01-DEVELOPMENT (arm64)
built on Tue Nov 08 16:16:38 UTC 2022
FreeBSD 14.0-CURRENT

Related issues

Has duplicate Bug #13564: PHP error after creating a Route MapResolvedReid Linnemann

Actions
Actions #1

Updated by Jim Pingle 3 months ago

  • Parent task set to #13446
Actions #2

Updated by Reid Linnemann 3 months ago

  • Assignee set to Reid Linnemann
Actions #3

Updated by Danilo Zrenjanin 3 months ago

Tested against:

2.7.0-DEVELOPMENT (amd64)
built on Fri Nov 11 06:06:08 UTC 2022
FreeBSD 14.0-CURRENT

I couldn't replicate the issue with Global FRR switch on. Is there anything specific that needs to be set in FRR?

Actions #4

Updated by Alhusein Zawi 3 months ago

The issue occurs when adding a route map

PHP errors:
PHP ERROR: Type: 1, File: /usr/local/pkg/frr/inc/frr_zebra.inc, Line: 418, Message: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/pkg/frr/inc/frr_zebra.inc:418
Stack trace:
#0 /usr/local/pkg/frr/inc/frr_zebra.inc(821): frr_zebra_generate_routemaps()
#1 /usr/local/pkg/frr.inc(669): frr_generate_config_zebra()
#2 /usr/local/www/pkg_edit.php(245) : eval()'d code(2): frr_generate_config()
#3 /usr/local/www/pkg_edit.php(245): eval()
#4 {main}

23.01-DEVELOPMENT (amd64)
built on Fri Nov 11 06:05:57 UTC 2022
FreeBSD 14.0-CURRENT

Actions #5

Updated by Danilo Zrenjanin 3 months ago

There is a different redmine for that issue:
https://redmine.pfsense.org/issues/13564

Actions #6

Updated by Reid Linnemann 3 months ago

Root cause of this appears to be an empty <config> element being written under the frrglobalroutemaps package. Due to how <config> is treated as a list element in the xml parser, this results in installedpackages/frrglobalroutemaps/config being an array of size 1 with an empty string element, and that empty string element is expected to be an array by the package code.

Actions #7

Updated by Reid Linnemann 3 months ago

  • Status changed from New to Confirmed
Actions #8

Updated by Reid Linnemann 3 months ago

  • Status changed from Confirmed to In Progress
Actions #9

Updated by Reid Linnemann 2 months ago

  • Status changed from In Progress to Feedback

Fixed in 4a256a0

Actions #10

Updated by Jim Pingle 2 months ago

  • % Done changed from 0 to 100
Actions #11

Updated by Reid Linnemann about 2 months ago

  • Has duplicate Bug #13564: PHP error after creating a Route Map added
Actions #12

Updated by Reid Linnemann about 2 months ago

I had neglected originally to bump the portrevision, so the package was not actually rebuilt. That has been done as of c17f51a

Actions #13

Updated by Jim Pingle about 2 months ago

  • Status changed from Feedback to Resolved

This appears to be OK on a current snap with the latest package (After removing some leftover debug prints in the base).

It cleaned up the bad tag and I can also list and create route map entries.

Actions

Also available in: Atom PDF