Project

General

Profile

Actions

Bug #13566

open

pfSense - Feature #13446: Upgrade PHP from 7.4 to 8.1

Non-devel pfBlocker Package Broken in 2.7 CE with PHP 8.1

Added by Kris Phillips 4 months ago. Updated 3 days ago.

Status:
Feedback
Priority:
Normal
Category:
pfBlockerNG
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
23.01
Affected Version:
Affected Plus Version:
Affected Architecture:

Description

Several PHP 8.1-related bugs are fixed in the devel version, but these persist in the stable release.

Going to the Alerts screen produces this error:
Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/www/pfblockerng/pfblockerng_alerts.php:486 Stack trace: #0 {main} thrown in /usr/local/www/pfblockerng/pfblockerng_alerts.php on line 486 PHP ERROR: Type: 1, File: /usr/local/www/pfblockerng/pfblockerng_alerts.php, Line: 486, Message: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/www/pfblockerng/pfblockerng_alerts.php:486 Stack trace: #0 {main} thrown

Attempting to run updates produces the following error:
PHP ERROR: Type: 1, File: /usr/local/www/pfblockerng/pfblockerng_update.php, Line: 392, Message: Uncaught TypeError: fclose(): Argument #1 ($stream) must be of type resource, string given in /usr/local/www/pfblockerng/pfblockerng_update.php:392
Stack trace:
#0 /usr/local/www/pfblockerng/pfblockerng_update.php(392): fclose('/var/log/pfbloc...')
#1 {main}
thrown

There may be more errors present.

Actions #1

Updated by Reid Linnemann 3 months ago

  • Assignee set to Reid Linnemann

BBCan177 is currently finalizing changes for pfBlockerNG-devel for 2.7/ 23.01. When those are submitted, devel and non-devel will be synced.

Actions #2

Updated by Jim Pingle 3 months ago

  • Parent task set to #13446
Actions #3

Updated by Christian McDonald 5 days ago

  • Status changed from New to Feedback
  • Assignee changed from Reid Linnemann to Christian McDonald
  • Target version set to 2.7.0
  • Plus Target Version set to 23.01

security/pfSense-pkg-pfBlockerNG-devel has been copied to security/pfSense-pkg-pfBlockerNG.

The versions of both have been bumped to 3.2.0

v2 is no longer available on 2.7+ and 23.01+

Actions #4

Updated by Kris Phillips 3 days ago

I'm assuming this will have to wait for the RC release, as I don't see this reflected in the BETA repos. Both versions are still available there.

Actions

Also available in: Atom PDF