Project

General

Profile

Actions

Regression #13614

closed

Feature #13446: Upgrade PHP from 7.4 to 8.1

Cannot Edit Firewall Rules - 2.7.0-DEVELOPMENT (amd64) built on Mon Oct 31 06:05:27 UTC 2022

Added by RED SKULL 3 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Category:
Web Interface
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.01
Release Notes:
Force Exclusion
Affected Version:
2.7.0
Affected Architecture:
amd64

Description

Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/www/firewall_rules_edit.php:1709 Stack trace: #0 {main} thrown in /usr/local/www/firewall_rules_edit.php on line 1709 PHP ERROR: Type: 1, File: /usr/local/www/firewall_rules_edit.php, Line: 1709, Message: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/www/firewall_rules_edit.php:1709 Stack trace: #0 {main} thrown


2.7.0-DEVELOPMENT (amd64)
built on Mon Oct 31 06:05:27 UTC 2022
FreeBSD 14.0-CURRENT

The system is on the latest version.
Version information updated at Mon Oct 31 13:40:49 CDT 2022


Files

image.png (48.5 KB) image.png RED SKULL, 10/31/2022 02:21 PM
Actions #1

Updated by Chris W 3 months ago

  • Status changed from New to Resolved

Unable to reproduce on CE 2.7.0.a.20221101.0600. I can successfully edit the default LAN allow rule and create new rules on the LAN and WAN interfaces.

I'll mark this as Resolved but let us know if there's anything additional we should know to reproduce the error.

Actions #2

Updated by Reid Linnemann 3 months ago

  • Status changed from Resolved to In Progress
  • Assignee set to Reid Linnemann

There's a direct config array access here that needs to be replaced with the accessor func.

Actions #3

Updated by Reid Linnemann 3 months ago

  • Status changed from In Progress to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Jim Pingle 3 months ago

  • Target version set to 2.7.0
  • Parent task set to #13446
  • Plus Target Version set to 23.01
  • Release Notes changed from Default to Force Exclusion
Actions #5

Updated by Jim Pingle 3 months ago

  • Tracker changed from Bug to Regression
Actions #6

Updated by Lev Prokofev about 2 months ago

Don't see listed errors on

2.7.0-DEVELOPMENT (amd64)
built on Fri Dec 09 06:13:30 UTC 2022
FreeBSD 14.0-CURRENT

Actions #7

Updated by RED SKULL about 2 months ago

no more errors. Good to close out

Actions #8

Updated by Jim Pingle about 2 months ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF