Project

General

Profile

Actions

Regression #13629

closed

Uncaught TypeError: Cannot access offset of type string on string in /usr/local/www/services_dhcp.php

Added by Louis B 3 months ago. Updated about 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Force Exclusion
Affected Version:
2.7.0
Affected Architecture:
All

Description

when switching a vlan related DHCP-server off there is a php crash (2.7 bsd 14)

Fatal error: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/www/services_dhcp.php:454 Stack trace: #0 {main} thrown in /usr/local/www/services_dhcp.php on line 454 PHP ERROR: Type: 1, File: /usr/local/www/services_dhcp.php, Line: 454, Message: Uncaught TypeError: Cannot access offset of type string on string in /usr/local/www/services_dhcp.php:454 Stack trace: #0 {main} thrown


Files

PHP_errors.log (976 Bytes) PHP_errors.log php crash log Louis B, 11/04/2022 01:42 PM
DHCPconfig.JPG (108 KB) DHCPconfig.JPG Louis B, 11/05/2022 01:26 PM
phperrors.JPG (48.6 KB) phperrors.JPG Louis B, 11/05/2022 01:31 PM
dhcpd.conf (10.4 KB) dhcpd.conf Louis B, 11/10/2022 03:15 AM
dhcpdv6.conf (3.55 KB) dhcpdv6.conf Louis B, 11/10/2022 03:15 AM

Related issues

Is duplicate of Regression #13719: PHP8.1 error when saving DHCP Server settings.ResolvedMarcos M

Actions
Actions #1

Updated by Danilo Zrenjanin 3 months ago

I couldn't replicate this issue on the:

2.7.0-DEVELOPMENT (amd64)
built on Fri Nov 04 06:05:19 UTC 2022
FreeBSD 14.0-CURRENT

Did you have any specific DHCP server settings on the VLAN interface?

Actions #2

Updated by Louis B 3 months ago

At this moment I am running the same version and did the test again. No problem to reproduce the problem at all.
I do not have any special thing defined. Never the less I attached a screenshot of the config (as far as used)

A few additional remarks which could be help full perhaps (I hope ....)
- I have defined 16 interfaces / vlans
- all having dhcp IPV4
- and all having dhcp6 and RA (mostly managed two assisted)
- some vlans have dhcp4 static mappings mac to ipv4

Actions #3

Updated by Louis B 3 months ago

here a copy of the messages from a few minutes ago

Actions #4

Updated by Chris W 3 months ago

Unable to reproduce on build 2.7.0.a.20221104.0600, upgraded from 2.6.

I created a new VLAN, gave it an allow all firewall rule, enabled the DHCP server. Once it started, dhcpd was running and I was able to disable the DHCP server on the VLAN like normal. Same result after a reboot, and nothing indicating any problems in Status > System Logs > DHCP.

Do you see this error only for the same VLAN each time, or is it not specific to any one?

Actions #5

Updated by Louis B 3 months ago

No, the problem occurs probably on every vlan. More precise if I enable or disable the dhcp server and hit save its there.

Note that I did upgrade a few days ago from the old 2.7 (12.3) to the new 2.7 (14 stable) via a new install using the saved config on an usb during that install

Actions #6

Updated by Jim Pingle 3 months ago

  • Target version set to 2.7.0
  • Parent task set to #13446
  • Plus Target Version set to 23.01
  • Release Notes changed from Default to Force Exclusion
Actions #7

Updated by Jim Pingle 3 months ago

  • Tracker changed from Bug to Regression
Actions #8

Updated by Danilo Zrenjanin 3 months ago

I tested again against the:

2.7.0-DEVELOPMENT (amd64)
built on Wed Nov 09 06:04:35 UTC 2022
FreeBSD 14.0-CURRENT

I enabled dhcp6, RA, and dhcp4 static mappings as instructed. Yet, I couldn't reproduce the issue.

Can you provide us with the dhcpd.conf and dhcpdv6.conf files?

They are located in the /var/dhcpd/etc/ folder.

Actions #9

Updated by Louis B 3 months ago

Here my DHCP configfiles

Actions #10

Updated by Jim Pingle about 2 months ago

  • Status changed from New to Duplicate
  • Target version deleted (2.7.0)
  • Parent task deleted (#13446)
  • Plus Target Version deleted (23.01)

This was duplicated by #13719 and a fix was put in there.

Actions #11

Updated by Jim Pingle about 2 months ago

  • Is duplicate of Regression #13719: PHP8.1 error when saving DHCP Server settings. added
Actions

Also available in: Atom PDF