Project

General

Profile

Actions

Bug #14301

closed

Input validation error when saving IGMP Proxy settings

Added by Kris Phillips 12 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Category:
IGMP Proxy
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.09
Release Notes:
Default
Affected Version:
Affected Architecture:
All

Description

When attempting to add interfaces to IGMP Proxy or make any configuration changes, there is an error stating "There was a problem applying the changes. See the System Logs." This was reported in redmine https://redmine.pfsense.org/issues/13277

However, when testing today, I'm unable to get Multicast traffic to traverse from an upstream interface to a downstream interface.

With two interfaces LAN1 and LAN2, I started a UDP multicast stream from VLC on port 10000 on multicast address 224.0.0.1. I can see the traffic in a packet capture on the LAN1 interface as shown here:

22:26:12.993227 IP 172.21.92.146.45203 > 224.0.0.1.10000: UDP, length 1316
22:26:12.994176 IP 172.21.92.146.45203 > 224.0.0.1.10000: UDP, length 1316
22:26:14.019534 IP 172.21.92.146.45203 > 224.0.0.1.10000: UDP, length 1316

However, when running the same capture on the LAN2 interface, I see no packets being proxied across the subnets. The IGMP service starts, seems to be running, and other than the webConfigurator error it seems to throw no errors in the System logs, but it simply doesn't appear to be doing anything.


Related issues

Related to Bug #14665: IGMP Proxy cannot start on VirtIO (``vtnet``) interfacesResolvedKristof Provost

Actions
Has duplicate Bug #13277: IGMP Proxy webConfigurator Page Always Produces ErrorDuplicate

Actions
Actions #1

Updated by Jim Pingle 12 months ago

  • Project changed from pfSense Plus to pfSense
  • Category changed from IGMP Proxy to IGMP Proxy
  • Status changed from New to Feedback
  • Affected Plus Version deleted (23.01)

Can this be reproduced on 23.05? Are you sure this isn't the same problem as #13929 ?

Actions #2

Updated by Kris Phillips 12 months ago

Jim Pingle wrote in #note-1:

Can this be reproduced on 23.05? Are you sure this isn't the same problem as #13929 ?

Hello Jim,

I haven't tested this on 23.05, but I did make sure that igmpproxy was updated per that bug report with the same results.

Actions #3

Updated by Kris Phillips 10 months ago

Tested in 23.05.1-RC and this still seems to be present.

Actions #4

Updated by Marcos M 9 months ago

  • Subject changed from IGMP Seems Non-functional in pfSense Plus 23.01 to Correct input validation when saving IGMP Proxy settings
  • Status changed from Feedback to Pull Request Review
  • Assignee set to Kristof Provost
  • Target version set to 2.8.0
  • Plus Target Version set to 23.09
Actions #5

Updated by Marcos M 9 months ago

  • Subject changed from Correct input validation when saving IGMP Proxy settings to Input validation error when saving IGMP Proxy settings
Actions #6

Updated by Kristof Provost 9 months ago

Note that that's mostly only a cosmetic problem. It does actually start igmpproxy.
I'm investigating another issue, which I suspect to be limited to virtio interfaces, and possibly only those on bhyve, but as I said: I'm still investigating.

Actions #7

Updated by Kristof Provost 9 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #8

Updated by Kristof Provost 9 months ago

The virtio issue did turn out to be a virtio problem. It doesn't allow IFF_ALLMULTI to be set (on systems where the host doesn't announce VIRTIO_NET_F_CTRL_RX support), so igmpproxy couldn't start.
https://reviews.freebsd.org/D41356 will fix that.

Actions #9

Updated by Jim Pingle 9 months ago

  • Related to Bug #14665: IGMP Proxy cannot start on VirtIO (``vtnet``) interfaces added
Actions #10

Updated by Jim Pingle 9 months ago

I made a dedicated issue for the VirtIO problem at #14665

Actions #11

Updated by Jim Pingle 9 months ago

  • Has duplicate Bug #13277: IGMP Proxy webConfigurator Page Always Produces Error added
Actions #12

Updated by Jim Pingle 9 months ago

I also created a feature request for an option to handle the firewall rules we discussed: #14666

Actions #13

Updated by Kris Phillips 8 months ago

Tested on Aug 18th builds of Plus 23.09. No errors are present when saving IGMP Proxy anymore. This can be closed as resolved.

Actions #14

Updated by Jim Pingle 8 months ago

  • Status changed from Feedback to Resolved
Actions #15

Updated by Jim Pingle 6 months ago

  • Target version changed from 2.8.0 to 2.7.1
Actions

Also available in: Atom PDF