Project

General

Profile

Actions

Regression #15337

closed

pfSense-boot pkg fails install in UFS

Added by Steve Wheeler 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Category:
Upgrade
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Release Notes:
Force Exclusion
Affected Plus Version:
24.03
Affected Architecture:
All

Description

Upgrading UFS installs to the current 24.03 snapshot fails when running the POST-INSTALL script inb the pfSense upgrade pkg:

Installed packages to be UPGRADED:
    pfSense-boot: 24.03.b.20240312.0600 -> 24.03.b.20240313.0600 [pfSense-core]

Number of packages to be upgraded: 1
[1/1] Upgrading pfSense-boot from 24.03.b.20240312.0600 to 24.03.b.20240313.0600...
[1/1] Extracting pfSense-boot-24.03.b.20240313.0600: .......... done
/bin/sh: Syntax error: end of file unexpected (expecting "fi")
pkg-static: POST-INSTALL script failed
 failed.
Failed

This appears to be caused by the script truncating the UFS ID:

+ mount -p
+ awk '$2 ~ /^\/$/ { match($1, "[[:alpha:]/]+[[:digit:]]+"); print substr($1, RSTART, RLENGTH); }'
+ bootdevs=/dev/ufsid/6023315
+ mount -p
+ awk '$2 ~/\/boot\/efi/'
+ [ -n '' ]
+ gpart show -p /dev/ufsid/6023315
+ awk '$4 ~ /efi/ {print $3}'
gpart: No such geom: /dev/ufsid/6023315.

Actions #1

Updated by Christian McDonald 3 months ago

  • Assignee set to Reid Linnemann
Actions #2

Updated by Reid Linnemann 3 months ago

The regex to capture the root disk dev is insufficient, as the root partition can show up as a label as well as a partition device. Fix incoming.

Actions #3

Updated by Reid Linnemann 3 months ago

  • Assignee changed from Reid Linnemann to Christian McDonald
Actions #4

Updated by Reid Linnemann 3 months ago

  • Assignee deleted (Christian McDonald)

Assigned to Christian as he has changes in the works to move all of this boot code management into pfSense-upgrade and dike out the boot template package altogether.

Actions #5

Updated by Jim Pingle 3 months ago

  • Status changed from New to Feedback
  • Assignee set to Christian McDonald

IIRC this is fixed now, or at least needs re-tested on current snaps.

Actions #6

Updated by Georgiy Tyutyunnik 3 months ago

tested on:
24.03-BETA (amd64)
built on Fri Mar 22 17:08:00 UTC 2024
FreeBSD 15.0-CURRENT
upgraded from 23.09.1 on UFS system, no issues detected, no pfSense-boot package upgrade in logs

Actions #7

Updated by Marcos M 3 months ago

  • Status changed from Feedback to Resolved
  • Release Notes changed from Default to Force Exclusion
Actions

Also available in: Atom PDF