Project

General

Profile

Actions

Bug #2406

closed

No IP alias within the subnet of a CARP IP can be deleted

Added by Chris Buechler over 9 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Low
Category:
Virtual IP Addresses
Target version:
Start date:
05/01/2012
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:

Description

The input validation that triggers:

$input_errors[] = gettext("This entry cannot be deleted because it is still referenced by a CARP IP with the description") . " {$vip['descr']}.";

prevents the deletion of any IP alias within the subnet of a defined CARP IP. It's intended to keep you from shooting yourself in the foot and breaking your CARP on that subnet, but it should only prohibit deleting the last IP alias within a CARP IP's subnet as it's perfectly valid to delete any additional IP aliases within that subnet.

It can be worked around by editing the IP alias VIP and changing its IP subnet or subnet mask, then deleting the IP alias, as that same input validation is not done upon editing.

Actions #1

Updated by Renato Botelho almost 9 years ago

  • Assignee set to Renato Botelho
  • Target version set to 2.1
Actions #2

Updated by Renato Botelho almost 9 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #3

Updated by Richard Adams almost 9 years ago

Using:
2.1-BETA1 (amd64)
built on Thu Feb 21 23:02:24 EST 2013
FreeBSD 8.3-RELEASE-p6

with the latest gitsync.

The problem is not fixed. The error still appears when you try to move the IPAlias VIP.

Actions #4

Updated by Jim Pingle almost 9 years ago

  • Status changed from Feedback to New
  • % Done changed from 100 to 0
Actions #5

Updated by Renato Botelho almost 9 years ago

  • Status changed from New to Feedback

As proposed on bug description, the error still shows up when you try to remove the last IP alias, but do not complain when you remove additional ones. Are you getting it when trying to remove additional ones? If yes, please, post the <virtualip> section of your config.xml here.

Actions #6

Updated by Richard Adams almost 9 years ago

It is the last one. pfSense should be able to determine if the alias type is CARP or IP Alias and let you remove any (even the last one) IP Alias. How are IP Aliases referenced by CARP interfaces?
I tested again going from 2 to one IP Alias left and it was able to delete all but the last IP Alias.

Actions #7

Updated by Chris Buechler almost 9 years ago

  • Status changed from Feedback to Resolved

This is fixed. You can't remove the last IP alias on the subnet of a CARP IP because it'll break CARP, you have to delete the CARP IP first. The only exception being when the interface IP is on the CARP IP's subnet, which is also handled correctly.

Actions #8

Updated by Nei Ka about 7 years ago

Chris Buechler wrote:

This is fixed. You can't remove the last IP alias on the subnet of a CARP IP because it'll break CARP, you have to delete the CARP IP first. The only exception being when the interface IP is on the CARP IP's subnet, which is also handled correctly.

This is still a problem. I have a CARP alias. I added another virtual IP in the same network for testing. I then could not delete the VIP. I had to delete the CARP IP then the VIP, then re-add the CARP IP.

Actions

Also available in: Atom PDF