Project

General

Profile

Bug #295

UID error in User Manager/SSH password sync with Web Admin User

Added by Angel Torres over 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
User manager
Target version:
Start date:
01/12/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

New install of 2.0 Beta from jan 8, 2010 using a 2.0 config.xml backup. Web Admin User password is not the same as SSH password (default 'pfsense'). Have to go to User Manager and type password anew to sync passwords between SSH and Web Admin. This works and does sync passwords but I get the following error when clicking Save:

Warning: chown(): Unable to find uid for username in /etc/inc/auth.inc on line 307 Warning: chown(): Unable to find uid for username in /etc/inc/auth.inc on line 314 Warning: chown(): Unable to find uid for username in /etc/inc/auth.inc on line 318 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/auth.inc:307) in /etc/inc/functions.inc on line 69

Associated revisions

Revision ee23ccab (diff)
Added by Ermal Luçi about 9 years ago

Ticket #295. Use empty to prevent some ghost entries in some configurations.

History

#1 Updated by Chris Buechler over 9 years ago

  • Status changed from New to Closed

The password sync portion is a duplicate of #287.

I can't replicate the "Unable to find uid for username" portion, so I believe it's since been fixed. If you can still replicate that part when a new snapshot is available (newer than January 16), please add details on how to do so.

#2 Updated by Angel Torres over 9 years ago

I'm still seeing this on the Jan 18 Snapshot. Only reason I can assume that you're not seeing it is possibly because this config was upgraded from a 1.2.3. So try changing username and pw in 1.2.3 from admin/pfsense, upgrade to 2.0 and then try changing the password in 2.0 with that username.

#3 Updated by Angel Torres over 9 years ago

Yes confirmed, just formatted disk and freshly installed 1.2.3. Upgrade to 2.0, the unable to find uid for XXX error flashes during the initial boot process after the firmware upgrade, right before the rrd graphs are updated.

#4 Updated by Chris Buechler over 9 years ago

  • Status changed from Closed to New
  • Priority changed from Normal to Low

Thanks for the details, must affect upgraded configurations only.

#5 Updated by Ermal Luçi over 9 years ago

  • Status changed from New to Feedback

I cannot replicate it on latest snapshot how ever i tried.
Please test it and report also attach the config.xml before and after upgrade if you see problems.

#6 Updated by Larry Titus about 9 years ago

There is still a password sync issue as of pfSense-2.0-BETA1-20100324-1017. When upgrading from 1.2.3. to this snapshot the SSH password is reset back to its default "pfsense". The WebUI password remains the same as it was under 1.2.3. Setting the password via the WebUI after the upgrade syncs the SSH password with the WebUI password again.

#7 Updated by Chris Buechler about 9 years ago

  • Status changed from Feedback to New

#8 Updated by Erik Fonnesbeck about 9 years ago

This is probably related to an issue I've seen that the root/admin password on the console is not updated after I do an upgrade + config restore (nanobsd platform; I upgrade from 1.2.3, reset to defaults, then restore my 2.0 config). I think it may have to do with these lines in /etc/rc.bootup:

echo "Synchronizing user settings...";
if (!isset($config['system']['webgui']['backend']))
    local_sync_accounts();
echo "done.\n";

That setting looks like this in my config (with other stuff removed):

<system>
    <webgui>
        <backend/>
    </webgui>
</system>

Meaning that it is set. Should it maybe be using empty() instead of !isset()? I don't know a lot about that setting or the internals of the user manager, so I'm not really sure.

#9 Updated by Erik Fonnesbeck about 9 years ago

Looking through the history, this "backend" setting seems to be something that was removed, so this check in /etc/rc.bootup probably needs to be changed to something else entirely.

#10 Updated by Ermal Luçi about 9 years ago

  • Status changed from New to Feedback

#11 Updated by Seth Mos about 9 years ago

  • Status changed from Feedback to Resolved

I recently committed code for alternate usernames in ticket #574 for alternate usernames on upgrades. That also produced the can not find uid for <user>.

I confirmed that both the root and admin account have the correct password in snapshot 2010-05-16

Also available in: Atom PDF