Project

General

Profile

Bug #3856

Delete a user, edit another one and going back... delete the edited user

Added by Jerome Troussard almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
User manager
Target version:
Start date:
09/10/2014
Due date:
% Done:

100%

Affected Version:
All
Affected Architecture:
All

Description

In the user manager page, if you delete a user and then go to the edit page for another user, when you click the browser back button, the edited user is deleted.
(I hope my description is understandable...)

Associated revisions

Revision 1a6769a6
Added by Renato Botelho almost 4 years ago

Replace GET by POST on system_usermanager.php and make necessary adjustments on necessary pages. It fixes #3856

Revision fbe0d698
Added by Renato Botelho over 3 years ago

Be more strict on user removal checking array id and also username to avoid removing wrong users when browser back button is used. It should fix #3856

Revision 7ea27b0d
Added by Renato Botelho over 3 years ago

Be more strict on removing groups checking group id and group name, it avoids issues like happened to users on ticket #3856. While I'm here, replace GET by POST

History

#1 Updated by Renato Botelho almost 4 years ago

  • Assignee set to Renato Botelho
  • Priority changed from High to Normal
  • Target version set to 2.2

Confirmed. Will work on a fix

#2 Updated by Renato Botelho almost 4 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#3 Updated by Thiago Basilio almost 4 years ago

Bug still persists.

If you have a system with two users added (say "test1" and "test2"):
> In the "User manager" page:
>> Delete user "test1" 
>>> Click on the edit icon for user "test2" 
>>>> On the edit page for user "test2", clicking "back" button on the browsers cause itself to ask to resend information, and then, "test2" user will be deleted too.

,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,
pfSense: pfSense 2.2-BETA amd64
Browser: Firefox ESR 24.8.0 win32
``````````````````````````````````

#4 Updated by Renato Botelho almost 4 years ago

  • Status changed from Feedback to New

#5 Updated by Renato Botelho over 3 years ago

  • Status changed from New to Feedback

#6 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

This seems to be fixed, and fixed a similar but different issue I'd run into but not opened a ticket for yet.

Also available in: Atom PDF