Project

General

Profile

Actions

Feature #4176

closed

Add support for SMTP authentication mechanisms

Added by Russell Morris almost 7 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Category:
Notifications
Target version:
Start date:
01/04/2015
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:

Description

This may apply to more than Office365 mail, but it does impact this mail system for sure. Details (and the fix) are at this link https://forum.pfsense.org/index.php?topic=72015.new;topicseen#new.

The issue overall is allowing support for email systems that require SMTP Authentication using LOGIN, not PLAIN (as is the default / hard coded now). Perhaps just add a pull-down, to select LOGIN or PLAIN, and then apply this?

Thanks!

Actions #1

Updated by Phillip Davis almost 7 years ago

Proposed implementation of this: https://github.com/pfsense/pfsense/pull/1421
It works for me on a mail server that accepts both PLAIN and LOGIN.
Does this make it work for you on Office365?

Actions #2

Updated by Jim Thompson almost 7 years ago

I'm not sure how to test this. (I don't want an Office365 Mail account.)

Actions #3

Updated by Phillip Davis almost 7 years ago

Confirmed that pull request 1421 code is working for the user in forum: https://forum.pfsense.org/index.php?topic=86226.msg473100#msg473100

Actions #4

Updated by Renato Botelho almost 7 years ago

  • Project changed from pfSense Packages to pfSense
  • Subject changed from Support for Office365 Mail to Add support for SMTP authentication mechanisms
  • Category set to Notifications
  • Assignee set to Renato Botelho
  • Target version changed from 2.2 to 2.2.1

Provide a better description and move it to future since we are in RC

Actions #5

Updated by Russell Morris almost 7 years ago

Hi,

Not a huge issue, just trying to understand - so this won't be included in the near future? Only asking because my email notifications are completely broken (and the same for other folks it seems), and the fix is pretty minor.

Thanks!

Actions #6

Updated by Renato Botelho almost 7 years ago

I targeted it to 2.2.1, it'll be committed to RELENG_2_2 after 2.2 is released, and a gitsync will bring it to 2.2. I understand it's not a big patch but we need to stop adding new things to get the 2.2 release done.

While it doesn't happen, you can install 'System Patches' package on your system and apply the patch proposed using the URL https://github.com/pfsense/pfsense/pull/1421.diff

Actions #7

Updated by Renato Botelho almost 7 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Pull request has been merged

Actions #8

Updated by Chris Buechler over 6 years ago

  • Status changed from Feedback to Resolved

works

Actions

Also available in: Atom PDF