Project

General

Profile

Bug #4398

Userlist - No sorting anymore

Added by Stefan Fl├╝gger over 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Low
Category:
User manager
Target version:
Start date:
02/10/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2.x
Affected Architecture:

Description

The Userlist in pfSense was changed in Version 2.2. Now there is no option sorting the user by name. Before a doubleclick on the top line of the list worked fine on user and loginname. And what is this checkbox for in the first column?

History

#1 Updated by Phillip Davis over 4 years ago

And what is this checkbox for in the first column?
You can select multiple users and then delete them with 1 click (bottom right "x" - delete selected users)
I guess that the column sort got lost in changing to the template that allows multi-row selection and action.

#2 Updated by Chris Buechler over 4 years ago

  • Project changed from pfSense Packages to pfSense
  • Category set to User manager
  • Status changed from New to Confirmed
  • Target version changed from 2.2.1 to 2.2.2

#3 Updated by Chris Buechler over 4 years ago

note the sort is there if you have 1 user only, disappears with > 1. I'm sure Phil's right on that. Moving to 2.2.2 since it's non-critical.

#4 Updated by Chris Buechler over 4 years ago

  • Target version changed from 2.2.2 to 2.2.3

#5 Updated by Chris Buechler about 4 years ago

  • Target version changed from 2.2.3 to 2.3

#6 Updated by Jim Thompson almost 4 years ago

  • Assignee set to Steve Beaver

If this is target 2.3, then I'm assigning to Beaver, because the GUI code there is all Bootstrap

#7 Updated by Chris Buechler almost 4 years ago

the bootstrap user manager table isn't sortable, so this is an issue, if it's something we care enough to do. If it's easy enough, great. If not, no issue pushing it off.

#8 Updated by Steve Beaver over 3 years ago

User table (and many others throughout the system) now sortable.

See: #5405

#9 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

#10 Updated by Jim Pingle over 3 years ago

  • Status changed from Feedback to Resolved

List is definitely sorting in 2.3 now, tested it for that other ticket and again now.

The checkbox is there but the multi-delete button is missing, but that should be in a separate ticket since it's unrelated to sorting

#11 Updated by Chris Buechler over 3 years ago

  • Affected Version changed from 2.2 to 2.2.x

Also available in: Atom PDF