Project

General

Profile

Bug #4424

Adding and removing shaper repeatedly causing interface crash

Added by Kill Bill over 4 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Traffic Shaper (ALTQ)
Target version:
-
Start date:
02/13/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.2
Affected Architecture:
All

Description

Since at least one other user confirmed that, filing the bug here - relevant forum thread: https://forum.pfsense.org/index.php?topic=88675.0

0. Make a backup of your shaper settings if you have some in place, remove the shaper after that.
1. Go to Firewall - Traffic Shaper - WAN, set up a quick shaper like this

(The bandwidth does not matter for this test, can be empty as well.)
2. Browse for a minute or two to check that the shaper is in place and works (Status - Queues).
3. Remove the shaper.
4. Wash, rinse, repeat steps 1-3 a couple more times if still alive.

This managed to kill WAN in 3-4 cycles on any box I tried. PPPoE with DHCP, cable modem with fixed IP, ... does not matter. (Probably "works" with other interfaces as well)

History

#1 Updated by Jeroen Roovers over 4 years ago

About a month ago I tried to set up a shaper on the LAN interface and got a similar result. The web interface was blocked, no traffic flowed on the LAN interface but the other interfaces continued to work properly.

I was unable to properly debug this as after I got locked out, but it appeared that some configuration files had been corrupted in the process, because after a reboot, the web interface no longer started, complaining of a missing group, which was confirmed since the group file was now missing.

I restored a 2.1 system image backup and restored an old enough configuration in order to restore service and investigated no further.

#2 Updated by Phillip Davis over 4 years ago

I guess you had to power cycle the box some time after getting locked out, so maybe the group file missing on bootup in that case is https://redmine.pfsense.org/issues/4519 "Full installs are suffering disk corruption on reboot/power loss".
So you suffered from both this Traffic Shaper issue, then issue 4519 as a bonus :)

#3 Updated by Ben Cook over 4 years ago

I frequently see this bug as well.

A reliable work-around I use is to first Disable/Uncheck & Apply then finally "Remove" the queue and I get no crashes. If Remove is the first action taken on an active queue, my web GUI cbecomes inaccessible, though it did return once after about 3 minutes.

#4 Updated by Kill Bill almost 4 years ago

Considering there's been zero progress here solving the core issue... the Remove Shaper button should be either inactive as long as there's an active queue on the interface, or it should be smart enough to do what's stated in the above comment itself before removing the shaper. This bug is completely unacceptable with remotely managed boxes.

#5 Updated by Jim Thompson almost 3 years ago

  • Assignee set to Luiz Souza

With luck recent work has closed this.

#6 Updated by Jim Pingle about 1 month ago

  • Status changed from New to Closed

Old report and no recent recurrences. Lots of things in this area have changed, so most likely it's either fixed no longer relevant.

Also available in: Atom PDF