Project

General

Profile

Bug #4921

Disabling a gateway does not remove static routes for DNS servers set to use it

Added by Steve Wheeler over 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
Gateways
Target version:
Start date:
08/05/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

After disabling a gateway in System > Routing, Gateways if you have DNS servers defined in System > General Setup that are tied to that gateway they are not removed from the routing table. That means you can no longer access those servers at all. Additionally if you then check for that in System > General Setup the DNS server will appear to be set to use gateway 'none' because the actual gateway is no longer available in the drop down so it's very easy to miss.

Associated revisions

Revision 138e4140 (diff)
Added by Renato Botelho almost 4 years ago

Remove static routes to DNS servers when gateway is disabled. It should fix #4921

History

#1 Updated by Jim Pingle over 4 years ago

  • Category set to Gateways
  • Target version set to 2.3
  • Affected Version set to 2.2.x

#2 Updated by Jim Thompson over 4 years ago

  • Assignee set to Renato Botelho

#3 Updated by Chris Buechler about 4 years ago

  • Status changed from New to Confirmed
  • Affected Version changed from 2.2.x to All

#4 Updated by Renato Botelho almost 4 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#5 Updated by Chris Buechler almost 4 years ago

  • Status changed from Feedback to Resolved

works

Also available in: Atom PDF