Project

General

Profile

Actions

Bug #5200

closed

Invalid DHCP Pool notice is a tad too aggressive

Added by Jim Pingle about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
DHCP (IPv4)
Target version:
Start date:
09/24/2015
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.2.5
Affected Architecture:

Description

Running through the setup wizard on 2.2.5 results in multiple notices about an invalid DHCP pool before the wizard finishes. Might need to dial that back a bit somehow.

It was introduced in 89735da238ed1b173942bdc24e4bc2f4c8543555

Actions #1

Updated by Jim Pingle about 6 years ago

  • Affected Version changed from 2.2.x to 2.2.5
Actions #2

Updated by Phillip Davis about 6 years ago

After running the wizard and changing the LAN IP it calculates a new DHCP range for LAN. Then I get 3 notices about "Invalid DHCP pool" for the new DHCP pool range, complaining that it is not in the OLD LAN subnet. I guess the code there is implementing some DHCP changes before it switches the LAN IP. I will have a look and see if the whole implementation of LAN IP plus LAN DHCP pool range can be done together to avoid ever having an inconsistent run-time state.

Actions #3

Updated by Phillip Davis about 6 years ago

See pull request https://github.com/pfsense/pfsense/pull/1935 for a possible solution to this.

Actually in theory this should never happen, the sequence of "reload all" at the end of the setup wizard should never pass through inconsistent stages where the implemented interface IP address/CIDR settings and DHCP pools are not matched. But that looks like another big job to sort out exactly what goes on through each stage of that.

Actions #4

Updated by Phillip Davis about 6 years ago

Also pull request https://github.com/pfsense/pfsense/pull/1938 has a solution with a bit more logging.
Take your pick.

Actions #5

Updated by Jim Pingle about 6 years ago

The fix in pull request 1938 works great for me, thanks Phil, we'll get that imported.

Actions #6

Updated by Renato Botelho about 6 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

Merged, thanks!

Actions #7

Updated by Chris Buechler about 6 years ago

  • Status changed from Feedback to Resolved

works

Actions

Also available in: Atom PDF