Project

General

Profile

Bug #5441

Unbound config does not bind to CARP IP

Added by Jeremy Porter almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DNS Resolver
Target version:
Start date:
11/13/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

After upgrading a working 2.2.5 system, there was no name resolution on the LAN. Lan is set to query the Carp VIP for DNS. Changing Unbound config to add the CARP interface IP as an assigned interface does not work. It does not appear to update the unbound.conf file to include the IP. Temporary workaround is to bind Unbound to all interfaces.

Associated revisions

Revision 2a5960b0 (diff)
Added by Luiz Souza over 3 years ago

Review of CARP uniqid changes.

It turns out that current CARP implementation is not much different from an IP alias.

This commit converts the IP alias to also use the CARP uniqid scheme, this simplify the code in all other places because now we have only two different cases to deal with:

- A friendly interface name (lan, wan, opt1, etc.);
- A Virtual IP - VIP alias (_vip{$uniqid}) - CARP or IP Alias.

The parent of a CARP is always a friendly interface. The parent of an IP alias can be a friendly interface or a CARP (this is the only case of recursion of a VIP).

This commit removes a few cases where CARP were still considered a interface (the old CARP implementation), fixes all the wrong cases of strpos() being used to detect a VIP address (wont work as it returns '0' which fails when tested as 'TRUE'), review the usage of CARP and IP alias as services bind addresses, fixes general issues of adding and editing VIP addresses.

The following subsystems were affected by this changes:

- IPSEC;
- OpenVPN;
- dnsmasq;
- NTP;
- gateways and gateway groups;
- IPv6 RA;
- GRE interfaces;
- CARP status;
- Referrer authentication.

Fixes (and/or revisit) the following tickets:

- Ticket #3257
- Ticket #3716
- Ticket #4450
- Ticket #4858
- Ticket #5441
- Ticket #5442
- Ticket #5500
- Ticket #5783
- Ticket #5844

History

#1 Updated by Jim Thompson almost 4 years ago

  • Assignee set to Renato Botelho

#2 Updated by Chris Buechler almost 4 years ago

  • Status changed from New to Confirmed

Unbound seems to have lost all knowledge of CARP IPs, they no longer show up in the interfaces list.

#3 Updated by Renato Botelho over 3 years ago

  • Status changed from Confirmed to Feedback

Maybe it was fixed by recent changes, I couldn't reproduce. On my tests I can see CARP IPs available on 'Network Interfaces' list

#4 Updated by Jeremy Porter over 3 years ago

I can retest, but this only happened on upgrade

#5 Updated by Renato Botelho over 3 years ago

  • Status changed from Feedback to Assigned

Nevermind, I'll test it on upgrade then

#6 Updated by Renato Botelho over 3 years ago

  • Assignee changed from Renato Botelho to Luiz Souza

Probably another side-effect of #4858

#7 Updated by Luiz Souza over 3 years ago

  • Status changed from Assigned to Feedback
  • % Done changed from 0 to 100

This is one of the issues already fixed in #4858 (similar to #5464).

#8 Updated by Tobias Wigand over 3 years ago

Also upgraded, from 2.2.6 to 2.3BETA from today.
https://forum.pfsense.org/index.php?topic=105451.0
Only one of 4 CARP IPs is selectable, the other 3 do not appear.

#9 Updated by Renato Botelho over 3 years ago

  • Status changed from Feedback to Assigned

#10 Updated by Chris Buechler over 3 years ago

  • Status changed from Assigned to Resolved
  • Assignee changed from Luiz Souza to Chris Buechler

this was fixed by my last commit on #4858

#11 Updated by Jim Thompson over 3 years ago

  • Assignee changed from Chris Buechler to Luiz Souza

#12 Updated by Jim Thompson over 3 years ago

Luiz apparently has a better fix.

#13 Updated by Jim Thompson over 3 years ago

  • Status changed from Resolved to Assigned

#14 Updated by Luiz Souza over 3 years ago

  • Status changed from Assigned to Resolved

This is now fixed. Thanks!

#15 Updated by Chris Buechler over 3 years ago

still works

Also available in: Atom PDF