Project

General

Profile

Bug #5450

GUI issues in IE on DNS Resolver and Forwarder

Added by Stilez y over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Target version:
Start date:
11/14/2015
Due date:
% Done:

0%

Estimated time:

Description

See attached screenshot:

1) custom options scrollbar has up and down buttons but no moving viewport locator, so you cant drag the viewport for the text area up or down
2) hosts+domains windows need a sensible minimum size

on IE 11 (at least)

resolver.png (21.8 KB) resolver.png Stilez y, 11/14/2015 03:02 PM
resolver2.png (8.83 KB) resolver2.png Stilez y, 11/14/2015 03:05 PM

History

#1 Updated by Stilez y over 3 years ago

Ditto "access lists" tab (see 2nd screenshot)

#2 Updated by jeroen van breedam over 3 years ago

what browser is this?

can not replicate this using firefox or chromium.

#3 Updated by Steve Beaver over 3 years ago

I don't see these issues either. I have tried FireFox, Safari and Chrome on the desktop, plus Safari and Firefox on OS-X.

#4 Updated by Chris Buechler over 3 years ago

  • Project changed from pfSense to Bootstrap
  • Status changed from New to Feedback
  • Affected Version set to 2.3

haven't seen that anywhere either.

Stilez: what browser and OS are you running?

#5 Updated by Stilez y over 3 years ago

this was IE 11 on Win 8.1, fresh install. I'll check for issues (microsoft's compatibility mode being on/off in particular)

#6 Updated by Stilez y over 3 years ago

In my defence - usually I'm on firefox! ;-)

#7 Updated by Jim Thompson over 3 years ago

  • Assignee set to Chris Buechler

ya run Windows, you get to evaluate IE bugs.

#8 Updated by Stilez y over 3 years ago

  • cries *

The engines cannae take it, cap'n! <<

#9 Updated by Chris Buechler over 3 years ago

  • Subject changed from GUI issues - dns resolver v2.3 to GUI issues in IE on DNS Resolver and Forwarder
  • Description updated (diff)
  • Status changed from Feedback to Confirmed
  • Assignee changed from Chris Buechler to Steve Beaver

This happens on services_dnsmasq.php as well as the unbound pages described using IE with compatibility mode disabled (the default).

If you enable compatibility mode, the entire GUI is broken, but that's probably to be expected and we don't care regardless.

That's IE 11 on Windows 8.1 and 10. The only other IE I had handy was IE 8 on Windows XP, which won't work by design. That correctly fails to connect via HTTPS (IE+WinXP doesn't support any current secure TLS options).

Everything else seems OK in IE, though I haven't extensively used it. I'll spend more of my testing time in IE, and groan.

I can get you into a Windows VM if you don't have one, Steve or others internally.

#10 Updated by Steve Beaver over 3 years ago

Dug an old laptop out of the basement and was able to reproduce. Also tested a work-around that seems effective. I will put it in place on the affected pages tomorrow.

#11 Updated by Steve Beaver over 3 years ago

  • Status changed from Confirmed to Feedback
  • Assignee changed from Steve Beaver to Chris Buechler

It seems that some versions of IE doesn't like tables that have an empty <tbody>. Those are now detected via jQuery and a dummy row is inserted. This has no visible effect on other browsers, but seems to fix the issue reported here on IE.

#12 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

yeah that does it, looks good

Also available in: Atom PDF