Project

General

Profile

Bug #5483

upgrading non-2.3 opposite slice with nanobsd fails

Added by Chris Buechler over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
High
Category:
Upgrade
Target version:
Start date:
11/19/2015
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

Take a 2.2.5 nano for instance, and upgrade one of the slices to 2.3. Then run an upgrade on 2.3. It'll attempt to upgrade the opposite still-2.2.5 slice, then reboots into a 2.2.5 slice that hasn't been upgraded.

Associated revisions

Revision 77764580 (diff)
Added by Renato Botelho over 3 years ago

Duplicate slice before upgrade, fixes #5483

History

#1 Updated by Phillip Davis over 3 years ago

As reported in this forum thread: https://forum.pfsense.org/index.php?topic=100603.0
I have pinged that thread a few times and ot no recent feedback about if it should be working or is an intended work-in-progress.
Anyway, good that it has a Redmine issue now.

#2 Updated by Phillip Davis over 3 years ago

As mentioned in that thread, one possible way to make the sequence work is for the 2.3 upgrade to first check the other slice to see if it has a pre-2.3 version (or has nothing or unrecognized rubbish). In that case, do a duplicate slice first so that the other slice has a matching 2.3.
Then the rest of the upgrade can proceed to upgrade to the other slice, which is now has a known-good 2.3 structure, in the standard way.

#3 Updated by Renato Botelho over 3 years ago

Phillip Davis wrote:

As mentioned in that thread, one possible way to make the sequence work is for the 2.3 upgrade to first check the other slice to see if it has a pre-2.3 version (or has nothing or unrecognized rubbish). In that case, do a duplicate slice first so that the other slice has a matching 2.3.
Then the rest of the upgrade can proceed to upgrade to the other slice, which is now has a known-good 2.3 structure, in the standard way.

Yeah, this is the first idea that came to my mind. I'll work on it. Thanks!

#4 Updated by Renato Botelho over 3 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#5 Updated by Phillip Davis over 3 years ago

Good stuff. I updated an APU from a 5 Nov 2015 2.3-ALPHA build on slice da0s1 to become
2.3-ALPHA (amd64)
built on Thu Nov 19 01:43:56 CST 2015
FreeBSD 10.2-STABLE

on da0s2

previously da0s2 had 2.2.5 on it.

The console said stuff about duplicating the slice and it seemed to do reasonable stuff, which succeeded.

#6 Updated by Jim Pingle over 3 years ago

I had some issues just now with an ALIX I had updated from 2.2.5. It was a fresh image of 2.2.5 upgraded to 2.3 so it was running off slice #2.

The first run failed, second run failed slightly differently, rebooted and then tried a third time and it worked.

Failed first run looked like this:

>>> Updating repositories... done.
**** WARNING ****
Duplicate slice required!!

Before start upgrade process, current mounted nanobsd partition
needs to be cloned to secondary partition, where update will happen

Proceed with upgrade? (y/N) y
mount: /dev/ufs/pfsense1: Device busy
>>> Cleaning secondary partition... done.
>>> Duplicating current slice... done.
>>> Restoring slice label... done.
>>> Mounting second partition to run upgrade... failed.

So it may at least need some more safety belts and testing.

#7 Updated by Phillip Davis over 3 years ago

The first time I tried it I got:

Enter an option: 13

>>> Updating repositories... done.
**** WARNING ****
Duplicate slice required!!

Before start upgrade process, current mounted nanobsd partition
needs to be cloned to secondary partition, where update will happen

Proceed with upgrade? (y/N) y
>>> Cleaning secondary partition... done.
>>> Duplicating current slice... ^[[28~done.
>>> Restoring slice label... done.
>>> Mounting second partition to run upgrade... done.
>>> Unlocking package pfSense-kernel-pfSense... done.
The following 8 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
        pfSense-rc: 2.3.a.20151119.0143 [pfSense-core]

Installed packages to be UPGRADED:
        strongswan: 5.3.3_1 -> 5.3.4 [pfSense]
        png: 1.6.18 -> 1.6.19 [pfSense]
        pfSense-kernel-pfSense: 2.3.a.20151105.1639 -> 2.3.a.20151119.0143 [pfSense-core]
        pfSense-default-config-serial: 2.3.a.20151105.1639 -> 2.3.a.20151119.0143 [pfSense-core]
        pfSense-base-nanobsd: 2.3.a.20151105.1639 -> 2.3.a.20151119.0143 [pfSense-core]
        pfSense: 2.3.a.20151103.0626 -> 2.3.a.20151118.0317 [pfSense]
        igmpproxy: 0.1 -> 0.1_2,1 [pfSense]

The process will require 72 KiB more space.
41 MiB to be downloaded.

**** WARNING ****
Reboot will be required!!
Proceed with upgrade? (y/N) y
Aborting...
>>> Locking package pfSense-kernel-pfSense... done.
*** Welcome to pfSense 2.3-ALPHA-nanobsd (amd64) on Kalikot-rt-01 ***

"Aborting..." had no reason mentioned. I think I pressed just a lowercase "y" and enter, like I copied from the console text output.

The 2nd time I watched carefully and it worked.

Note: There is a "^[[28~" in there - I have been getting little bits of rubbish like that lately on my serial console, not sure where the cause is. So I am not 100% sure if there is not some other "random" rubbish happening in addition to my typing. Thus I am not sure if this report is a genuine issue or not.

#8 Updated by Phillip Davis over 3 years ago

Hmmm - highlighting the console output text and pressing the "Inline Code" button has made a mess of the above. I have never been able to edit my posts in Redmine, so no way to fix it up.

#9 Updated by Jim Pingle over 3 years ago

Phillip Davis wrote:

Hmmm - highlighting the console output text and pressing the "Inline Code" button has made a mess of the above. I have never been able to edit my posts in Redmine, so no way to fix it up.

I edited it and used a pre tag around it, seems better now.

#10 Updated by Doug Dimick over 3 years ago

Commenting here per https://forum.pfsense.org/index.php?topic=102710.0 in case my issue is related.

I'm running a full install and not nano.

Upgrades fail if ramdisk is enabled. Additionally, both available and installed packages pages show as empty. Dashboard System Status states unable to check for updates. Turning off ramdisk resolves these issues.

#11 Updated by Renato Botelho over 3 years ago

Doug Dimick wrote:

Commenting here per https://forum.pfsense.org/index.php?topic=102710.0 in case my issue is related.

I'm running a full install and not nano.

Upgrades fail if ramdisk is enabled. Additionally, both available and installed packages pages show as empty. Dashboard System Status states unable to check for updates. Turning off ramdisk resolves these issues.

This ticket is for nanobsd upgrade when opposite partition contains non-2.3 version. If you still see problems with ramdisk enabled on full install please open a new bug

#12 Updated by Renato Botelho over 3 years ago

  • Status changed from Feedback to Resolved

Works

Also available in: Atom PDF