Project

General

Profile

Bug #6129

zabbix agent/proxy 2.4 not ported to pfSense 2.3

Added by James Lavoy about 4 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
-
Start date:
04/13/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:
All

Description

Hey there,

I saw on https://doc.pfsense.org/index.php/2.3_Removed_Packages that zabbix-agent-2 and zabbix-proxy-2 were not ported and that the intention was to use 2.2 as an alternative.

Unfortunately while the agents for zabbix are backwards compatible, the proxies are not. Please see https://www.zabbix.com/documentation/2.4/manual/appendix/compatibility

Therefore this change has caused pfSense to be unable to be used as a proxy if someone is using Zabbix server 2.4.

History

#1 Updated by Chris Buechler about 4 years ago

  • Assignee set to Renato Botelho

I'm not sure why we don't still have both of them. The GUI is identical with LTS which is already converted, and bringing it back will make people's lives easier on upgrade.

Renato (or anyone else): was there a reason we didn't convert zabbix2? Seems it should be simple to bring back unless there is some kind of pkg complication I'm unaware of.

#2 Updated by Pim Janssen almost 4 years ago

I would also like to see it come back. As we can't upgrade all our boxes to pf2.3 in one day we have a problem. 2.3 Does not work with zabbix 2.x and pf2.2 does not work with zabbix 3. So we have a problem here. I already requested to get zabbix proxy 3.x in pf 2.2 but that seems impossible. Now i hope getting zabbix proxy 2.2 support in pf2.3 is possible.

#3 Updated by Pim Janssen over 3 years ago

Is there any way i can help with this. Or is there anything i can do to make this happen?

#4 Updated by Heðin Ejdesgaard Møller about 3 years ago

Looks like a done case.

Currently zabbix agent and proxy 3.0 LTS is available in pfsense-2.3

#5 Updated by Jim Pingle about 3 years ago

  • Status changed from New to Resolved

#6 Updated by Pim Janssen about 3 years ago

@Jim
The issue is here because the 3.0 proxy is NOT backwards compatible. For that reason it would be good to have a 2.4/2.2 proxy.

#7 Updated by Jim Pingle about 3 years ago

  • Status changed from Resolved to New

If that is the case, it was not stated clearly anywhere on the problem description or even in the comments. Maybe if you read between the lines, but being vague is not how problems get solved.

#8 Updated by James Lavoy about 3 years ago

Jim Pingle wrote:

If that is the case, it was not stated clearly anywhere on the problem description or even in the comments. Maybe if you read between the lines, but being vague is not how problems get solved.

Zabbix 3.0 had barely been out 2 months when I made this report over a year ago. It's not unreasonable that a version that hadn't been bundled with pfSense at all at that time would have been mentioned in the report. However what was mentioned rather clearly is that Zabbix proxies in general are not backwards compatible.

I apologize if you didn't pick up on this, but it's hardly a case of the information being vague.

#9 Updated by Jim Pingle about 3 years ago

Information in a ticket needs to be precise and specific no matter when it's read. It is unreasonable to expect anyone to remember circumstances not mentioned in the ticket.

#10 Updated by James Lavoy about 3 years ago

I apologize, in the future I will be sure to track every version of software released everywhere and update my bug reports regularly to include all possible future versions as they come out.

#11 Updated by James Lavoy about 3 years ago

James Lavoy wrote:

Therefore this change has caused pfSense to be unable to be used as a proxy if someone is using Zabbix server 2.4.

For all future viewers of this ticket: This issue now makes pfSense unable to be used as proxy if the user is using Zabbix Server 2.4, 3.0, 3.2, 3.4 or higher. If we want users to be able to use pfSense as a proxy, packages will need to be added for all of these versions.

#12 Updated by Pim Janssen about 3 years ago

4.0 LTS Will be added in september 2017. I think having only LTS releases would be enough.

#13 Updated by James Lavoy about 3 years ago

Pim Janssen wrote:

4.0 LTS Will be added in september 2017. I think having only LTS releases would be enough.

Yeah, I think supporting LTS only is a reasonable compromise.

Information on their release cycles is here: http://www.zabbix.com/life_cycle_and_release_policy

Current LTS versions are 2.2, 3.0, and soon to be 4.0.

#14 Updated by Brendon Baumgartner almost 3 years ago

Zabbix agents can be any version.

Zabbix proxies have to match the version of the Zabbix server so just supporting LTS here for the proxy is very limiting.

#15 Updated by Pim Janssen almost 3 years ago

Brendon Baumgartner wrote:

Zabbix proxies have to match the version of the Zabbix server so just supporting LTS here for the proxy is very limiting.

Supporting all versions is a lot of work. Supporting ALL supported LTS versions is a good alternative. It's not easy to upgrade for most organisations. So most will run LTS anyway.

#17 Updated by Jim Pingle over 2 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF