Project

General

Profile

Bug #6153

RFC 2136 Client fails to update more than 1 record

Added by Ken Bass about 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Dynamic DNS
Target version:
Start date:
04/14/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
All
Affected Architecture:
Release Notes:
Default

Description

I added a single RFC 2186 Client (name1.mydomain.com) and verified it worked. DNS was updated and 'cached IP' was green.
I then added an additional entry (name2.mydomain.com), all other parameters the same. It did not work - client page showed N/A.

System log shows 'Not updating name1.mydomain.com A record because the IP address has not changed'
System log shows 'Not updating name2.mydomain.com A record because the IP address has not changed'

Edited entry and presses 'Force and Save update' - same problem.
Manually ran rc.dyndns.update - same problem and log message.

There was only a single /conf/dyndns_wan_rfc2136_'name1.mydomain.com'_ns.mydomain.com.cache
I had to delete that file (note: there was no name2 file). Then it worked.

Associated revisions

Revision ed680fda (diff)
Added by Renato Botelho over 4 years ago

Fix #6153

Initialize cached IP and Time on loop for RFC2136 items, without this
the items used on last loop iteration will be used again and second
item on the same interface will not be updated

Revision e2a059e2 (diff)
Added by Renato Botelho over 4 years ago

Fix #6153

Initialize cached IP and Time on loop for RFC2136 items, without this
the items used on last loop iteration will be used again and second
item on the same interface will not be updated

History

#1 Updated by Jim Thompson about 5 years ago

  • Assignee set to Chris Buechler

#2 Updated by Chris Buechler almost 5 years ago

  • Category set to Dynamic DNS
  • Status changed from New to Confirmed
  • Assignee deleted (Chris Buechler)
  • Target version set to 2.4.0
  • Affected Version changed from 2.3 to All

#3 Updated by Renato Botelho over 4 years ago

  • Subject changed from RFC 2186 Client fails to update more than 1 record to RFC 2136 Client fails to update more than 1 record

#4 Updated by Renato Botelho over 4 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#5 Updated by Renato Botelho over 4 years ago

  • Assignee set to Jim Pingle

Pingle has a way to validate the changes

#6 Updated by Jim Pingle over 4 years ago

  • Status changed from Feedback to Resolved

Works for me. Two RFC2136 entries on WAN both get updated now. I wiped the cache files and tested using /etc/rc.dyndns.update and both entries are processed.

#7 Updated by Jim Pingle about 4 years ago

  • Target version changed from 2.4.0 to 2.3.3

Also available in: Atom PDF