Project

General

Profile

Actions

Bug #7307

closed

ZFS installer - shuts down instead of rebooting

Added by Clinton Cory almost 5 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Start date:
02/23/2017
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4
Affected Architecture:

Description

Using the following image: pfSense-netgate-memstick-ADI-2.4.0-BETA-amd64-latest.img (downloaded today)

When performing an install using the ZFS file-system, the last prompt during the install appears to perform a shutdown rather than a reboot.

The last prompt indicates a completed install and has an option to reboot. When this option is selected I see the shutdown process begin:

Waiting (max 60 seconds) for system process `bufdaemon' to stop... done
Waiting (max 60 seconds) for system process `syncer' to stop... 
Syncing disks, vnodes remaining... 0 0 0 done
All buffers synced.
Uptime: 3m17s

It will just hang there. I have to physically power cycle the device to perform the reboot. I've confirmed this on multiple hardware models (ie: SG-2220, SG-8860). This behavior does not occur when selecting the UFS filesystem.

Actions #1

Updated by Jim Thompson almost 5 years ago

  • Assignee set to Renato Botelho
Actions #2

Updated by Jim Thompson about 4 years ago

  • Target version set to 2.4.2
Actions #3

Updated by Jim Pingle about 4 years ago

This appears to only happen when installing ZFS to eMMC on SG boxes using the ADI image. Installing to SSD reboots normally.

Actions #4

Updated by Jim Pingle about 4 years ago

  • Target version changed from 2.4.2 to 2.5.0

Given that this only happens when using eMMC, and the operator is already present at the hardware to perform the installation, this isn't a blocker. Moving forward.

Actions #5

Updated by Renato Botelho over 2 years ago

  • Assignee changed from Renato Botelho to Clinton Cory

Clinton,

Can you check if it's still happening on 2.5.0 snapshots?

Actions #6

Updated by Jim Pingle about 1 year ago

  • Status changed from New to Feedback
Actions #7

Updated by Kris Phillips 11 months ago

This issue is no longer present in Jan 8th builds of pfSense when installing with ZFS.

Actions #8

Updated by Jim Pingle 11 months ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF