Project

General

Profile

Bug #7786

traffic shaping queue on WAN wont allow total of all child to be 100%

Added by Bipin Chandra almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Traffic Shaper
Target version:
Start date:
08/19/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.x
Affected Architecture:

Description

i was setting up traffic shaping on a sg-1000, i found 2 issues:

firstly on wan i added a qinternet and set it to 70mbps and then created 5 child queues under that and it totals to 100% but it wont allow that, max i can goto is 99%. The same i do on the lan interface then it allows total to be 100%.

secondly if u create a qinternet under wan a a child queue called qack under that and then u try to clone that to lan then the tree is lost and qinternet and qack both end up under tha lan interface

Associated revisions

Revision fbbd7d2b (diff)
Added by Steve Beaver over 1 year ago

Crudely fixed #7786 by eliminating check of parent bandwidth when children are sepcified in %

History

#1 Updated by Jim Thompson almost 2 years ago

  • Priority changed from High to Normal

#2 Updated by Renato Botelho almost 2 years ago

  • Target version changed from 2.4.0 to 2.4.1

#3 Updated by Jim Pingle almost 2 years ago

  • Target version changed from 2.4.1 to 2.4.2

Moving target to 2.4.2 as we need 2.4.1 sooner than anticipated.

#4 Updated by Bipin Chandra almost 2 years ago

i think this requires some php code changes only as the web gui doesnt allow, the shaper itself is fine with it when edited manually

#5 Updated by Jim Thompson almost 2 years ago

  • Assignee set to Steve Beaver

#6 Updated by Steve Beaver over 1 year ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#7 Updated by James Dekker over 1 year ago

On pfSense-netgate-uFW-recover-2.4.2-DEVELOPMENT-armv6-20171104-1805 unable to reproduce. Created parent queue for 50Mb/s, then a child at 100% with no issue, same with 50% and 50% child queues.

Can be set to resolved.

#8 Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Resolved

Looks good here, too.

Also available in: Atom PDF