Project

General

Profile

Bug #7917

GUI shows "There are no packages currently installed" when repos are unreachable

Added by Kill Bill about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
Package System
Target version:
Start date:
10/08/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4
Affected Architecture:
All

Description

# pkg info | grep pfSense-pkg
pfSense-pkg-AutoConfigBackup-1.47 pfSense package AutoConfigBackup
pfSense-pkg-Cron-0.3.7_2       pfSense package Cron
pfSense-pkg-FTP_Client_Proxy-0.3_3 pfSense package FTP_Client_Proxy
pfSense-pkg-Lightsquid-3.0.6_4 pfSense package Lightsquid
pfSense-pkg-RRD_Summary-1.3.2_2 pfSense package RRD_Summary
pfSense-pkg-Service_Watchdog-1.8.4 pfSense package Service_Watchdog
pfSense-pkg-Shellcmd-1.0.3     pfSense package Shellcmd
pfSense-pkg-Status_Traffic_Totals-1.2.1_1 Traffic Totals using the vnStat database
pfSense-pkg-System_Patches-1.1.7 pfSense package System_Patches
pfSense-pkg-acme-0.1.19_1      pfSense package acme
pfSense-pkg-arping-1.2.2_1     pfSense package arping
pfSense-pkg-freeradius3-0.15.1 FreeRADIUS 3.x package for pfSense
pfSense-pkg-iftop-0.17_2       pfSense package iftop
pfSense-pkg-mtr-nox11-0.85.6_1 pfSense package mtr-nox11
pfSense-pkg-nmap-1.4.4_1       pfSense package nmap
pfSense-pkg-openvpn-client-export-1.4.14 pfSense package openvpn-client-export
pfSense-pkg-pfBlockerNG-2.1.1_10 pfSense package pfBlockerNG
pfSense-pkg-squid-0.4.39       pfSense package squid
pfSense-pkg-sudo-0.3           pfSense package sudo
pfSense-pkg-suricata-4.0.0_1   pfSense package suricata
pfSense-pkg-tftpd-0.1.3_1      pfSense package for tftp server

Sigh.

History

#1 Updated by S. Debreuil about 2 years ago

Same issue. It appears after upgrade to 2.4.0.r.20171007.0850 (from 2.4.0.r.20171004.xxxx).

#2 Updated by Kill Bill about 2 years ago

Stephane Debreuil wrote:

Same issue. It appears after upgrade to 2.4.0.r.20171007.0850 (from 2.4.0.r.20171004.xxxx).

AFAICT the repos have been taken down on purpose due to major screw-up [1]. Please note that this bug has nothing to do with upgrade, it happens every time the repos cannot be reached and the package list cannot be downloaded. The package manager GUI doesn't work in offline mode at all.

[1] https://forum.pfsense.org/index.php?topic=137682.0

#3 Updated by Jim Pingle about 2 years ago

  • Assignee set to Renato Botelho
  • Target version set to 2.4.2

See also: #7946

#4 Updated by Renato Botelho about 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

I've confirmed fix pushed for #7946 also fix it

#5 Updated by James Dekker about 2 years ago

installed a package, pulled WAN, went back to Packages and the package showed. Rebooted without WAN, checked again, package showed.

#6 Updated by Renato Botelho about 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF