Project

General

Profile

Feature #9521

Upgrade to HAProxy 1.9

Added by S. Debreuil 5 months ago. Updated about 11 hours ago.

Status:
Pull Request Review
Priority:
Normal
Category:
haproxy
Target version:
Start date:
05/12/2019
Due date:
% Done:

0%

Estimated time:

Description

Some of our backends support HTTP/2, but it seems that HAProxy 1.8 only support HTTP/2 for the frontends.
The latest major version of HAProxy 1.9 support end-to-end HTTP/2.

Is there a plan to upgrade to HAProxy 1.9?

History

#1 Updated by Torben Hørup 4 months ago

haproxy 2.0 LTS has beeen released. better to use that one instead.

#2 Updated by S. Debreuil 4 months ago

Torben Hørup wrote:

haproxy 2.0 LTS has beeen released. better to use that one instead.

Right. 1.9 is a stable version but not LTS, while 2.0 is LTS.

#3 Updated by Torben Hørup 3 months ago

haproxy 2.0 is available in ports 2019Q3

#4 Updated by Torben Hørup about 15 hours ago

now that pfsense/FreeBSD-ports has been updated to ports 2019Q3 i think it would make sense to bump haproxy versions

pfSense-pkg-haproxy should bump from haproxy17 to haproxy18
pfSense-pkg-haproxy-devel should bump from haproxy18 to haproxy (2.0 branch)

See https://github.com/pfsense/FreeBSD-ports/pull/687

#5 Updated by Renato Botelho about 11 hours ago

  • Status changed from New to Pull Request Review
  • Assignee set to Renato Botelho

Also available in: Atom PDF