Project

General

Profile

Bug #9647

hn0: driver does not support altq

Added by Greg M over 1 year ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Traffic Shaper (ALTQ)
Target version:
Start date:
07/24/2019
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.5.0
Affected Architecture:

Description

As subject says, hn0 on 2.5.0 does not support ALTQ.
You get error after traffic shaper wizard starts to reload rules.

Output of: sysctl -a | grep use_if_start
Is: hw.hn.use_if_start: 0

Associated revisions

Revision 2360abcc (diff)
Added by Luiz Souza 3 months ago

Fix #9647.

Instead of forcing the defaults in the OS driver (introducing yet another
change), set the default to enable ALTQ support for hnX NICs in loader.conf.

Ticket: #9647

Revision 154a8854 (diff)
Added by Luiz Souza 3 months ago

Fix the repeated entries in loader.conf.

Ticket: #9647

Revision 14d2f872 (diff)
Added by Luiz Souza 3 months ago

Add a system option to handle the queue API usage in hn NICs.

A single queue is used in order to enable the ALTQ support, but some people may
prefer performance over the ALTQ features.

Ticket: #9647

History

#1 Updated by Jim Pingle about 1 year ago

  • Category set to Traffic Shaper (ALTQ)

See previous issue #8954 where this was fixed for 2.4.4

#2 Updated by Greg M 9 months ago

Hi,
are there any plans to correct this behaviour?
Is this possibly resolved in next freebsd release?

Thanks!

#3 Updated by Greg M 9 months ago

#4 Updated by Dee D 8 months ago

still an issue on the latest builds...

#5 Updated by Greg M 6 months ago

Hello.

Can someone please take a look at this one?
It seems trivial to fix or am I wrong?

#7 Updated by Jim Pingle 5 months ago

  • Status changed from New to Pull Request Review

#8 Updated by Renato Botelho 5 months ago

  • Assignee set to Luiz Souza
  • Target version set to 2.5.0

Luiz, can you check this one please?

#9 Updated by Luiz Souza 4 months ago

  • Status changed from Pull Request Review to Resolved
  • % Done changed from 0 to 100

Committed.

#10 Updated by Greg M 4 months ago

So I tried with: pfSense-CE-2.5.0-DEVELOPMENT-amd64-20200618-1024

Still same message about ALTQ support. Is this change baked into version I`ve tested?

Thanks!

#11 Updated by Jim Pingle 4 months ago

  • Status changed from Resolved to New

It should be. I also tested the most recent snapshot from this morning and altq did not work there, either.

#12 Updated by Greg M 4 months ago

I tried with todays snapshot and have the same issue.
What can we do next?

#13 Updated by Greg M 4 months ago

Hi!

Is there anything else to try?

#14 Updated by Greg M 3 months ago

So I did some more digging...

Added /boot/loader.conf.local with contents:

hw.hn.vf_transparent="0" 
hw.hn.use_if_start="1" 

And now shaper works just like on 2.4.5

#15 Updated by Luiz Souza 3 months ago

  • Status changed from New to Feedback

#16 Updated by Greg M 3 months ago

It works.
But did few reboots and there are MANY same settings added to loader.conf

Additional syntax error occurs, created redmine for that too.

#17 Updated by Greg M 3 months ago

And some more info...

This does NOT work:

kern.cam.boot_delay=10000
kern.ipc.nmbclusters="1000000"
kern.ipc.nmbjumbop="524288"
kern.ipc.nmbjumbo9="524288"
kern.geom.label.disk_ident.enable="0"
kern.geom.label.gptid.enable="0"
opensolaris_load="YES"
zfs_load="YES"
autoboot_delay="3"
hw.usb.no_pf="1"
vm.pmap.pti="0"
net.pf.request_maxcount="400000"
hw.hn.vf_transparent=0
hw.hn.use_if_start=1

But this DOES work:

kern.cam.boot_delay=10000
kern.ipc.nmbclusters="1000000"
kern.ipc.nmbjumbop="524288"
kern.ipc.nmbjumbo9="524288"
kern.geom.label.disk_ident.enable="0"
kern.geom.label.gptid.enable="0"
opensolaris_load="YES"
zfs_load="YES"
hw.hn.vf_transparent=0
hw.hn.use_if_start=1
autoboot_delay="3"
hw.usb.no_pf="1"
vm.pmap.pti="0"
net.pf.request_maxcount="400000"

So order matters I guess.

#18 Updated by Greg M 3 months ago

After 2 reboots file looks like this:

kern.cam.boot_delay=10000
kern.ipc.nmbclusters="1000000" 
kern.ipc.nmbjumbop="524288" 
kern.ipc.nmbjumbo9="524288" 
kern.geom.label.disk_ident.enable="0" 
kern.geom.label.gptid.enable="0" 
opensolaris_load="YES" 
zfs_load="YES" 
hw.hn.vf_transparent=0
hw.hn.use_if_start=1
hw.hn.vf_transparent=0
hw.hn.use_if_start=1
hw.hn.vf_transparent=0
hw.hn.use_if_start=1
autoboot_delay="3" 
hw.usb.no_pf="1" 
vm.pmap.pti="0" 
net.pf.request_maxcount="400000" 
hw.hn.vf_transparent=0
hw.hn.use_if_start=1

I guess it keeps adding those 2 lines.

#19 Updated by Luiz Souza 3 months ago

Sorry for the breakage, should be fixed now.

I couldn't reproduce the order issue, please let me know if this is still an issue.

#20 Updated by Greg M 3 months ago

Gitsynced, deleted all entries rebooted twice and it works.

Thanks.

#21 Updated by Luiz Souza 3 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF