Project

General

Profile

Actions

Feature #11164

closed

Input validation to prevent setting a load balancing gateway group as default

Added by Steve Wheeler 10 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Low
Category:
Gateways
Target version:
Start date:
12/15/2020
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
21.05
Release Notes:
Default

Description

Currently it's possible to set a load-balance gateway group as the system default gateway in System > Routing > Gateways.

That is an invalid setting though, only individual gateways or failover groups are valid there.

It would be nice for the input validation to prevent that but that would mean code to categorise gateway groups. That could get complex quickly.

Failing that a note on that page such as changing the text to:

Select a gateway or failover gatewaygroup to use as the default gateway.


Files

f_o.png (6.64 KB) f_o.png Alhusein Zawi, 04/21/2021 09:17 PM
Actions #1

Updated by Steve Wheeler 10 months ago

Reviewing it appears the intended behaviour here is that a load-balance group can be selected but behaves as a failover group with whichever gateway is first acrting as the higher tier. Importantly it cannot actually load-balance.

So a note to that effect on the page would probably suffice here.

Actions #2

Updated by Jim Thompson 8 months ago

  • Target version changed from Future to CE-Next

Seems simple enough to fix (with the message) and the GUI is misleading.

Actions #4

Updated by Jim Pingle 8 months ago

  • Status changed from New to Pull Request Review
Actions #5

Updated by Renato Botelho 7 months ago

  • Status changed from Pull Request Review to Feedback
  • Assignee set to Danilo Zrenjanin

PR has been merged. Thanks!

Actions #6

Updated by Renato Botelho 7 months ago

  • Target version changed from CE-Next to 2.6.0
Actions #7

Updated by Alhusein Zawi 6 months ago

note is added (attached)

2.6.0-DEVELOPMENT (amd64)
built on Wed Apr 21 01:03:55 EDT 2021
FreeBSD 12.2-STABLE

Actions #8

Updated by Viktor Gurov 6 months ago

  • Status changed from Feedback to Resolved
Actions #9

Updated by Jim Pingle 6 months ago

  • Plus Target Version set to 21.05

Already present on 21.05 builds.

Actions #10

Updated by Jim Pingle 6 months ago

  • Subject changed from Prevent setting a load-balance gateway group as default. to Input validation to prevent setting a load balancing gateway group as default

Updating subject for release notes.

Actions #11

Updated by Jim Pingle 5 months ago

  • Target version changed from 2.6.0 to 2.5.2
Actions

Also available in: Atom PDF