Project

General

Profile

Actions

Regression #13724

closed

pfSense-upgrade breaks the pkg repo conf

Added by Steve Wheeler about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Upgrade
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Release Notes:
Force Exclusion
Affected Plus Version:
23.01
Affected Architecture:
All

Description

Upgrades from 22.05 to 23.01 will fail with an error like:

ERROR: It was not possible to determine pkg remote version
__RC=1 __REBOOT_AFTER=10
>>> Updating repositories metadata... 
pkg-static: Unable to open '/usr/local/etc/pkg/repos//pfSense.conf':No such file or directory
No active remote repositories configured.
>>> Locking package pkg... done.

When you try to run the upgrade the pfSense-upgrade pkg is first pulled in from the Dev branch.
The pfSense-upgrade sh script there removes the symlink from /usr/local/etc/pkg/repos/pfSense.conf pointing to the existing static repo definitions. It replaces it with a link to the new dynamic repos location but it does so before the system has populated that. Hence the pkg system ends up without a conf file and fails.

Actions #1

Updated by Luiz Souza about 2 months ago

  • Status changed from New to Feedback

Fixed in the latest snapshot.

Only make the link after complete the repo settings download.

Actions #2

Updated by Nick Goehring about 2 months ago

on an SG5100 running 22.05. Attempting to switch to the 23.01 branch no longer breaks the upgrade/pkg function on my box. However, attempting to upgrade from the GUI results in a long wait as the browser spins and then a white screen. Attempting to update from the console/ssh yields a "failed to update the repository settings!!!" error. Also noticed that the label for the 23.01 branch now just says DEVEL version (devel)

Actions #3

Updated by Glenn Hall about 2 months ago

Working for me now. Was able to successfully upgrade from 22.05 to 23.01.a.20221209.1819.

Since the upgrade had previously failed for me, I had to set my update version in the GUI back to Latest Stable Version and then ran the following commands in the shell:

#pkg-static clean -ay; pkg-static install -fy pkg pfSense-repo pfSense-upgrade

Once those commands finished, I set the update version to DEV in the GUI and the update then worked.

Actions #4

Updated by Christian McDonald about 2 months ago

Thanks for the feedback!

Actions #5

Updated by Nick Goehring about 2 months ago

Happy to confirm that Glenn's approach worked for me as well now. After nearly a month of breakage, I'm back on the dev build. Thanks!

Actions #6

Updated by Jordan Greene about 2 months ago

Updating from 23.01.a.20221206.1416 to 23.01.a.20221210.0318 required running pkg update -f && pkg upgrade or being greeted with unable to update repositories. After being prompted to continue with the updates found and subsequently completing, it dropped back to console menu and did not prompt for reboot. Version appears correct and update check completes without issue following manual reboot.

Actions #7

Updated by Jim Pingle about 2 months ago

  • Status changed from Feedback to Resolved
  • Release Notes changed from Default to Force Exclusion
Actions

Also available in: Atom PDF