Project

General

Profile

Bug #6118

Packages renamed for 2.3 are not handled well, removed rather than installing using the new name

Added by jeroen van breedam over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Package System
Target version:
Start date:
04/12/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

snippet of system log:

Apr 12 23:54:39 pfsense php-cgi: rc.bootup: New alert found: Package Quagga OSPF does not exist in current pfSense version and it has been removed.

this was fixed by going in by ssh:

 pkg install pfSense-pkg-Quagga_OSPF

unfortunately this was a remote system that needed quagga to provide routes to reach it. Not a big issue

Associated revisions

Revision 291fad43 (diff)
Added by Chris Buechler over 3 years ago

Add config upgrade code to update package names. Ticket #6118

Revision 297ace66 (diff)
Added by Chris Buechler over 3 years ago

Add config upgrade code to update package names. Ticket #6118

Revision 538a3c04 (diff)
Added by Chris Buechler over 3 years ago

Revert "Add config upgrade code to update package names. Ticket #6118"

This reverts commit 291fad43870bdb39ef0ab32125b022e268a29cf7.

Revision 6086293b (diff)
Added by Chris Buechler over 3 years ago

Revert "Add config upgrade code to update package names. Ticket #6118"

This reverts commit 297ace668e4a4ffbf1fb1581e7c765e2ed158e29.

Revision ab2060d9 (diff)
Added by Chris Buechler over 3 years ago

Rename OSPF and System Patches packages in pre_upgrade_command. Ticket #6118

Revision 60ec2d7a (diff)
Added by Chris Buechler over 3 years ago

Rename OSPF and System Patches packages in pre_upgrade_command. Ticket #6118

History

#1 Updated by jeroen van breedam over 3 years ago

same system also had same issue for system-patches. Can't change title.
perhaps this is a general issue for more packages, but i didn't have any other installed on it.

Package System Patches does not exist in current pfSense version and it has been removed. @ 2016-04-12 23:54:38

#2 Updated by Phillip Davis over 3 years ago

I installed System Patches OK on a full install test system in a VM.
Then I tried to install it on a real Alix 32-bit that I have upgraded to 2.3-RELEASE. System Patches appears in the list of available packages. When I install it, I get:

Installing pfSense-pkg-System_Patches...

Updating pfSense-core repository catalogue...
pfSense-core repository is up-to-date.
Updating pfSense repository catalogue...
pfSense repository is up-to-date.
All repositories are up-to-date.
The following 1 package(s) will be affected (of 0 checked):

New packages to be INSTALLED:
pfSense-pkg-System_Patches: 1.1.4_1 [pfSense]

The process will require 31 KiB more space.
8 KiB to be downloaded.
Fetching pfSense-pkg-System_Patches-1.1.4_1.txz: . done
Checking integrity... done (0 conflicting)
[1/1] Installing pfSense-pkg-System_Patches-1.1.4_1...
[1/1] Extracting pfSense-pkg-System_Patches-1.1.4_1:

and it stops at that point and the GUI displays:
pfSense-pkg-System_Patches installation failed!

I tried installing something else that should be harmless and easy - Notes - and got the same sort of stuff.
Is there a general problem installing packages on Alix nanoBSD?

#3 Updated by Jim Pingle over 3 years ago

  • Subject changed from quagga install Upgrade 2.1.4 -> 2.3-release failed to Packages renamed for 2.3 are not handled well, removed rather than installing using the new name
  • Category set to Package System
  • Assignee set to Renato Botelho
  • Target version set to 2.3.1
  • Affected Version changed from 2.1.4 to 2.3

On 2.2.x the Quagga package is "Quagga OSPF" and on 2.3 it's "Quagga_OSPF". So the package still exists, but the space was changed to an underscore in its name. Removing it and stating that the package doesn't exist may be technically true by an exact name match, but it's unexpected and potentially harmful.

The upgrade code could handle that situation better. It affects at least Quagga and System patches.

#4 Updated by Renato Botelho over 3 years ago

Jim Pingle wrote:

On 2.2.x the Quagga package is "Quagga OSPF" and on 2.3 it's "Quagga_OSPF". So the package still exists, but the space was changed to an underscore in its name. Removing it and stating that the package doesn't exist may be technically true by an exact name match, but it's unexpected and potentially harmful.

The upgrade code could handle that situation better. It affects at least Quagga and System patches.

The code that checks for those packages uses tag <internal_name> to compare, and in this case it's Quagga_OSPF and System_Patches that should match

#5 Updated by Renato Botelho over 3 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Should be fixed on next round of 2.3.1-devel snapshots

#6 Updated by Chris Buechler over 3 years ago

I setup a test with 2.2.6 with Quagga OSPF and System Patches installed, upgraded it to 2.3.0 via auto-update (thinking I would confirm the breakage), and it worked fine. Packages installed, worked post-upgrade without touching it.

Renato: was this something fixed server-side in the pkg repo? no commit on the ticket, and don't see anything in the change log for the main repo that's related, so not sure what changed.

#7 Updated by Renato Botelho over 3 years ago

Chris Buechler wrote:

I setup a test with 2.2.6 with Quagga OSPF and System Patches installed, upgraded it to 2.3.0 via auto-update (thinking I would confirm the breakage), and it worked fine. Packages installed, worked post-upgrade without touching it.

Renato: was this something fixed server-side in the pkg repo? no commit on the ticket, and don't see anything in the change log for the main repo that's related, so not sure what changed.

I couldn't reproduce it either, but changes done for #6137 should help cases like this one to don't happen anymore.

#8 Updated by Chris Buechler over 3 years ago

This is only an issue upgrading from 2.1.x (and likely earlier but haven't tried).

#9 Updated by Chris Buechler over 3 years ago

pushed config upgrade code to rename those packages in the config. It looks like OSPF and System Patches are the only two that were renamed, but if anyone knows of others, please let us know.

#10 Updated by Chris Buechler over 3 years ago

the config upgrade code worked, or would have if it were actually in the config at that point. The pre_upgrade_command uninstalls all packages, so that's gone at the point convert_config runs. Reverted that config upgrade code, testing alternate approach.

#11 Updated by Chris Buechler over 3 years ago

  • Assignee changed from Renato Botelho to Chris Buechler

that works. leaving to test once it hits a snapshot.

#12 Updated by Chris Buechler over 3 years ago

Package list now correct, the package reinstall was skipped until my last commit on #6137. This succeeded with that change made manually, leaving for confirmation again once that hits a snapshot.

#13 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

works now

Also available in: Atom PDF