Project

General

Profile

Bug #6120

Password protect, baud on console menu not initially set post-upgrade on nanobsd and 2.3->2.3

Added by Pi Ba about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Console Menu
Target version:
Start date:
04/12/2016
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

Password protect the console menu, not effective after upgrade

After saving system/advanced settings again, the console locks itself. So easy to fix, but something to check..

upgrade_log.txt (8.15 KB) upgrade_log.txt Chris Buechler, 04/22/2016 03:52 AM
IMAG0865.jpg (1.61 MB) IMAG0865.jpg Greg M, 05/09/2016 12:03 PM

Associated revisions

Revision 14277cd6 (diff)
Added by Renato Botelho about 3 years ago

Add copies of pre|post upgrade script in /tmp on nanobsd images, they are used by old versions on this path. It fixes #6120

Revision 7efd78c9 (diff)
Added by Renato Botelho about 3 years ago

Add copies of pre|post upgrade script in /tmp on nanobsd images, they are used by old versions on this path. It fixes #6120

Revision 4cbe0b13 (diff)
Added by Renato Botelho about 3 years ago

Fix #6120

- Do not include /etc/ttys on base package, it's not supposed to be
replaced during upgrade
- Create a script /etc/rc.console_setup to make it easy to call
setup_serial_port() from shell scripts. This script will update
/etc/ttys accordingly
- Call /etc/rc.console_setup just after 2nd stage of upgrade happened
and new files are in place

Revision 1831d348 (diff)
Added by Renato Botelho about 3 years ago

Fix #6120

- Do not include /etc/ttys on base package, it's not supposed to be
replaced during upgrade
- Create a script /etc/rc.console_setup to make it easy to call
setup_serial_port() from shell scripts. This script will update
/etc/ttys accordingly
- Call /etc/rc.console_setup just after 2nd stage of upgrade happened
and new files are in place

Revision 32f0ee88 (diff)
Added by Renato Botelho about 3 years ago

Require system.inc to fix /etc/rc.console_setup. Ticket #6120

Revision 70f41755 (diff)
Added by Renato Botelho about 3 years ago

Revert "Require system.inc to fix /etc/rc.console_setup. Ticket #6120"

This reverts commit 32f0ee884632aba5ab38485a7c25c190bb5bccce.

History

#1 Updated by Jim Thompson about 3 years ago

  • Assignee set to Renato Botelho

#2 Updated by Chris Buechler about 3 years ago

  • File upgrade_log.txt upgrade_log.txt added
  • Subject changed from Password protect the console menu, not effective after upgrade to Password protect the console menu not initially set post-upgrade on nanobsd
  • Category set to Console Menu
  • Status changed from New to Confirmed

This is specific to nanobsd, and looks like it may have always happened in that situation. You end up with the default console setting until something triggers setup_serial_port().

post_upgrade_command.php doesn't appear to be running (successfully at least), nothing it logs ends up in upgrade_log.txt. Example attached. That's where it's intended to be set post-upgrade to ensure you don't have this situation.

#3 Updated by Chris Buechler about 3 years ago

  • Subject changed from Password protect the console menu not initially set post-upgrade on nanobsd to Password protect, baud on console menu not initially set post-upgrade on nanobsd

#4 Updated by Sam Bingner about 3 years ago

I don't think this is specific to nanobsd as I always used -full and have seen the same problem on all 4 firewalls I updated. Hitting save again fixes it as said in the initial report.

#5 Updated by Renato Botelho about 3 years ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 0 to 100

#6 Updated by Pi Ba about 3 years ago

Will it help for 'full' installs?

#7 Updated by Renato Botelho about 3 years ago

I'm testing full install right now and will let you know

#8 Updated by Renato Botelho about 3 years ago

Pi Ba wrote:

Will it help for 'full' installs?

I couldn't reproduce it on full install. I had a 2.2.5 VM with serial speed set to 9600, password protected console, ...

After upgrade to recent 2.3.1-devel snapshot all config worked as expected on first boot

#9 Updated by Greg M about 3 years ago

Hi!

It happens also on full install just tested it.
I have to save advanced settings then it prompts for login (on vga monitor, not console).
Then I do another snapshot update and it`s passwordless again.

#10 Updated by Renato Botelho about 3 years ago

Greg M wrote:

Hi!

It happens also on full install just tested it.
I have to save advanced settings then it prompts for login (on vga monitor, not console).
Then I do another snapshot update and it`s passwordless again.

Can you please provide more details about how to reproduce?

- What version should I install first?
- What settings I need to chose?
- What version I need to update to?

#11 Updated by Chris Buechler about 3 years ago

  • Status changed from Feedback to Confirmed

It happens on full installs going from 2.3->2.3.1 as well, just not from 2.2.x or earlier to 2.3.x.

#12 Updated by Pi Ba about 3 years ago

@Renato, for your reference yesterday evening i was testing and discussing with Chris with a fresh installation of pfSense-CE-2.3.1-DEVELOPMENT-amd64-20160505-0520.iso in a Virtualbox VM with 4 nics, 512MB memory, 4GB disk.
Installed pfSense with all default settings, locked console, then updated to new snapshot of 0506.1020 after reboot the console was unlocked.

The file /var/etc/disableconsole still exists, also the config option <disableconsolemenu/> is still there, only the /etc/ttys contains the wrong "al.Pc" value for ttyv0. Hope it helps fix this issue.

#13 Updated by Renato Botelho about 3 years ago

  • Status changed from Confirmed to Feedback

#14 Updated by Greg M about 3 years ago

See attached screen..
This happens on latest snap, maybe related?

#15 Updated by Renato Botelho about 3 years ago

Greg M wrote:

See attached screen..
This happens on latest snap, maybe related?

Yes, I reverted a commit on master and forgot RELENG_2_3. Fixed now, next snapshot should be OK

#16 Updated by Greg M about 3 years ago

Thanks, I can confirm working...

#17 Updated by Chris Buechler about 3 years ago

  • Subject changed from Password protect, baud on console menu not initially set post-upgrade on nanobsd to Password protect, baud on console menu not initially set post-upgrade on nanobsd and 2.3->2.3
  • Status changed from Feedback to Resolved

all works now

Also available in: Atom PDF