Project

General

Profile

Bug #6260

Namecheap Dynamic DNS does not accept * for hostname even though it is valid

Added by Luke Hamburg over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Dynamic DNS
Target version:
Start date:
04/25/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

Namecheap DDNS allows '*' (wildcard), but the page does not accept this value.

ddns2.png (15 KB) ddns2.png Luke Hamburg, 04/25/2016 09:25 AM

Associated revisions

Revision 84a67bf4 (diff)
Added by Chris Buechler over 3 years ago

Allow wildcard for hostname with Namecheap DDNS. Ticket #6260

Revision a1d059c2 (diff)
Added by Chris Buechler over 3 years ago

Allow wildcard for hostname with Namecheap DDNS. Ticket #6260

History

#1 Updated by Jim Pingle over 3 years ago

  • Status changed from New to Feedback

@ is already fixed -- see #6122

Try the fix on the ticket, if it works, this can be closed, if it still doesn't work for * then we can use this ticket for the * case.

#2 Updated by Luke Hamburg over 3 years ago

That patch addresses the @ but not the *

Still does not work for *

#3 Updated by Jim Pingle over 3 years ago

  • Subject changed from Dynamic DNS - does not accept @ or * chars for hostname even though they are valid to Namecheap Dynamic DNS does not accept * for hostname even though it is valid
  • Description updated (diff)
  • Category set to Dynamic DNS
  • Status changed from Feedback to New
  • Target version set to 2.3.1

OK I revised the ticket to be only for the * character.

#4 Updated by Chris Buechler over 3 years ago

  • Status changed from New to Confirmed
  • Target version changed from 2.3.1 to 2.3.2
  • Affected Version changed from 2.3 to All

that one's not as straight forward as changing the input validation, since the * needs changes in the back-end handling as well.

#5 Updated by Chris Buechler over 3 years ago

  • Status changed from Confirmed to Feedback

merged a slightly modified fix from PR 2770
https://github.com/pfsense/pfsense/pull/2770

Not sure that suffices though. Could someone with a Namecheap DDNS setup please try the next 2.3.2 snapshot with and without wildcards?

#6 Updated by Luke Hamburg over 3 years ago

Tested with pfSense-CE-2.3.2-DEVELOPMENT-amd64-20160702-0342 + Namecheap DDNS using `*` wildcard. Works! Testing was a little rough because the GUI (or PHP?) kept hanging on the status page, but I did check and confirm that the DNS was properly updated.

#7 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

Thanks Luke.

The delay there is from dyndns's checkip service being very slow to respond, there is another ticket covering that.

Also available in: Atom PDF