Project

General

Profile

Actions

Bug #6335

closed

Status > IPsec shows both connected and disconnected with Split Connections enabled

Added by Chris Linstruth over 5 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
Web Interface
Target version:
Start date:
05/08/2016
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.3.1
Affected Architecture:

Description

If an IPsec connection has split connections enabled, it shows both connected and disconnected in Status > IPsec. Disabling split connections eliminates display of both connected and disconnected rows but, since the other end is an ASA, breaks the VPN if multi-P2. See screen shot for 172.25.228.226 endpoint.

Appears to be only cosmetic.


Files

Actions #1

Updated by Chris Linstruth over 5 years ago

Appears to require a complete stop and restart of strongswan after enabling or disabling split connections to toggle the status display behavior. Or maybe just a manual disconnect/reconnect of the subject SA.

Actions #2

Updated by Chris Buechler over 5 years ago

  • Status changed from New to Confirmed
Actions #3

Updated by Chris Buechler over 5 years ago

  • Target version changed from 2.3.2 to 2.4.0
Actions #4

Updated by Jim Thompson almost 5 years ago

  • Assignee set to Renato Botelho
Actions #5

Updated by Renato Botelho about 4 years ago

  • Target version changed from 2.4.0 to 2.4.1
Actions #6

Updated by Jim Pingle about 4 years ago

  • Target version changed from 2.4.1 to 2.4.2
Actions #7

Updated by Jim Pingle about 4 years ago

  • Target version changed from 2.4.2 to 2.4.3
Actions #8

Updated by Jim Pingle about 4 years ago

  • Target version changed from 2.4.3 to 2.4.2

This is apparently also happening with IKEv2. If it turns out to be too much trouble, bump back to 2.4.3

Actions #9

Updated by Jim Pingle about 4 years ago

  • Assignee changed from Renato Botelho to Anonymous

Assigning to sjones since he's been working on other IPsec status issues

Actions #10

Updated by Anonymous about 4 years ago

  • Status changed from Confirmed to Resolved
Actions

Also available in: Atom PDF