Project

General

Profile

Bug #6335

Status > IPsec shows both connected and disconnected with Split Connections enabled

Added by Chris Linstruth over 3 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
Web Interface
Target version:
Start date:
05/08/2016
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3.1
Affected Architecture:

Description

If an IPsec connection has split connections enabled, it shows both connected and disconnected in Status > IPsec. Disabling split connections eliminates display of both connected and disconnected rows but, since the other end is an ASA, breaks the VPN if multi-P2. See screen shot for 172.25.228.226 endpoint.

Appears to be only cosmetic.

History

#1 Updated by Chris Linstruth over 3 years ago

Appears to require a complete stop and restart of strongswan after enabling or disabling split connections to toggle the status display behavior. Or maybe just a manual disconnect/reconnect of the subject SA.

#2 Updated by Chris Buechler over 3 years ago

  • Status changed from New to Confirmed

#3 Updated by Chris Buechler over 3 years ago

  • Target version changed from 2.3.2 to 2.4.0

#4 Updated by Jim Thompson over 2 years ago

  • Assignee set to Renato Botelho

#5 Updated by Renato Botelho about 2 years ago

  • Target version changed from 2.4.0 to 2.4.1

#6 Updated by Jim Pingle about 2 years ago

  • Target version changed from 2.4.1 to 2.4.2

#7 Updated by Jim Pingle about 2 years ago

  • Target version changed from 2.4.2 to 2.4.3

#8 Updated by Jim Pingle about 2 years ago

  • Target version changed from 2.4.3 to 2.4.2

This is apparently also happening with IKEv2. If it turns out to be too much trouble, bump back to 2.4.3

#9 Updated by Jim Pingle about 2 years ago

  • Assignee changed from Renato Botelho to Anonymous

Assigning to sjones since he's been working on other IPsec status issues

#10 Updated by Anonymous almost 2 years ago

  • Status changed from Confirmed to Resolved

Also available in: Atom PDF