Project

General

Profile

Actions

Bug #6856

closed

"Force Config Settings" buton on master causes slave to loss IP alises on lo0

Added by Pablo Ruiz almost 6 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
CARP
Target version:
-
Start date:
10/15/2016
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:

Description

Hi,

We have a two couple of node HA setup with pfsense latests version running (2.3.2p1). This cluster has a few virtual IPs (of IP Aliases type), configured, and everything works fine (ie. updating rules, host aliases, etc. works fine, gets replicated to slave, etc.). However if dare to manually force filter configuration by using the aformentioned button, during this replication the salve node losses it's IP aliases at lo0 device (verified by running 'ifconfig lo0' during de config sync process).

We can manually restore those aliases at slave by issuing /etc/rc.reload_interfaces at the console. But this, obviouslly, defeats the purpose of automatica HA. :?

I've tried this on previous (v2.2.5) versions, and I can confirm this version is affected aswell.

Actions #2

Updated by Steve Wheeler almost 6 years ago

Confirmed in 2.2.6 and 2.3.2_1 64bit.

Actions #3

Updated by Jim Thompson almost 6 years ago

  • Assignee set to Luiz Souza
Actions #4

Updated by Renato Botelho over 5 years ago

  • Project changed from pfSense Packages to pfSense
  • Category set to CARP
  • Priority changed from Very High to Normal
  • Target version set to 2.4.0
Actions #5

Updated by Jim Pingle over 5 years ago

  • Status changed from New to Duplicate

Duplicate of #7010 which is already fixed.

Actions #6

Updated by Jim Pingle over 5 years ago

  • Target version deleted (2.4.0)
Actions

Also available in: Atom PDF