Project

General

Profile

Bug #7625

When creating IPv6 firewall rule for single host, netmask improperly displays

Added by Chris Linstruth over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Web Interface
Target version:
Start date:
06/05/2017
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.3.4
Affected Architecture:

Description

When creating a firewall rule (I tested with a pass rule on WAN):

Address Family: IPv6
Source: Single Host or alias
Enter an IPv6 adress
Firefox and Chrome on Mac: displays /32 in source netmask
Safari on Mac: displays /128 in source netmask
Any change to Destination address hides source netmask in all tested cases.

This appears to be only cosmetic.

Causing confusion for at least one user: https://forum.pfsense.org/index.php?topic=131675.0

Associated revisions

Revision 036b32b5 (diff)
Added by Renato Botelho about 2 years ago

Fix #7625: Auto select '128' as mask for IPv6

Revision a98daee3 (diff)
Added by Renato Botelho about 2 years ago

Fix #7625: Auto select '128' as mask for IPv6

Revision 8150bd51 (diff)
Added by Steve Beaver about 2 years ago

Fixed #7625
By:
Separating the source and destination onChange functions
Preventing the mask selector from being automatically updated if it is disabled
Simplifying the auto mask JavaScript

History

#1 Updated by Renato Botelho about 2 years ago

  • Assignee set to Renato Botelho

#2 Updated by Renato Botelho about 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#3 Updated by Dan Lundqvist about 2 years ago

I have now updated to latest build but unfortunatly it still does not work. (2.4.0-BETA (amd64) built on Wed Aug 02 06:04:56 CDT 2017)

1. I create a IPv6 rule, select Src.SingleHotstOrAlias and enter a IPv6 address and press tab. It then fills in a /128 mask.
So far so good.

2. I then Select anything in the destination field like "SingleHotstOrAlias" and it still empties the Src.mask field to blank. Same as described in bug.

3. I then tried to empty the Dst. to Any and also empty the IPv6 address in Src and also even try to put back Src to "Any"
But it doesn't matter what you do the mask will be blank all the time even if you enter a new IPv6 address.

I even tried to do just #1 and then press SAVE without changing Dst and when you edit the rule Src.mask is still blank.

//Dan Lundqvist
Stockholm, Sweden

#4 Updated by Renato Botelho about 2 years ago

  • Status changed from Feedback to Assigned

#5 Updated by Renato Botelho about 2 years ago

  • Assignee changed from Renato Botelho to Steve Beaver

Steve will handle that

#6 Updated by Steve Beaver about 2 years ago

  • Status changed from Assigned to Feedback

Fixed JavaScript in firewall_rules_edit.php and pfSense.js

#7 Updated by Pi Ba about 2 years ago

Looks like it broke loading /interfaces.php?if=lan with static ip masks for both IPv4 and IPv6 now defaulting to 32 and 128. Instead of previously saved values.

#8 Updated by Jim Pingle about 2 years ago

  • Status changed from Feedback to Confirmed
  • Priority changed from Low to High

This has caused a regression, see #7777

In IPsec P2, and presumably other places, a stored IPv4 CIDR mask of /24 is jumping to /32 when an entry is edited, rather than using the correct mask.

#9 Updated by Jim Pingle about 2 years ago

It is also happening for Virtual IP addresses and their CIDR masks

#10 Updated by Steve Beaver about 2 years ago

  • Status changed from Confirmed to Feedback

#11 Updated by Jim Pingle about 2 years ago

That last change has corrected the behavior of CIDR selection for saved IPsec and VIPs, thanks!

#12 Updated by Jim Pingle about 2 years ago

  • Status changed from Feedback to Resolved

Looks OK all-around now.

Also available in: Atom PDF