Project

General

Profile

Bug #8639

Unable to boot zfs on root

Added by Ken Sim about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Category:
Operating System
Target version:
Start date:
07/11/2018
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.4.4
Affected Architecture:
All

Description

The current snapshot for 2.4.4 does not allow booting from zfs on root. It returns "failed with error 2: unknown file system."

Screenshot_07_11_2018_001.png (13.6 KB) Screenshot_07_11_2018_001.png Ken Sim, 07/11/2018 02:55 PM

History

#1 Updated by Raul Ramos about 1 year ago

On pFsense start press 3

One at a time
load /boot/kernel.old/kernel
load /boot/kernel.old/opensolaris.ko
load /boot/kernel.old/zfs.ko
boot

Until the problem is solved. (Do not update until a fix otherwise the kernel.old dir is populated with the new that have almost nothing)

built on Wed Jul 11 12:40:24 EDT 2018 only have "kernel" and "linker.hints" modules on /boot/kernel directory. Compiling problems?

Edit: after Manual installation "built on Thu Jul 12 08:51:04 EDT 2018" boots fine. I will see if an update give this error again.

#2 Updated by P Law about 1 year ago

This is a problem if your saved configuration backup is more recent than your last snapshot of the base system.

Steps:

1) Performed update, failed with issue noted here.
2) Restored snapshot of system from virtualization engine.
3) Base system is now older than most recent configuation if restored
4) Update from System -> Update complains and refused to update.

Tried wiping to defaults, but update fails (per this issue).

Why, oh why, can't we have the ability to update to OLD versions of base system??? My configuration is newer than my saved base system snapshot. Your latest update fails (miserably). So, I am left unable to restore latest configuration (without reinstalling from scratch???). You also don't keep older base system installers online indefinitely, limiting the time I can react to such problem as this.

#3 Updated by Ken Sim about 1 year ago

This issue is resolved with 2.4.4.a.20180712.1231 snapshot. Looks like it was an issue building zfs in the previous snapshots.

#4 Updated by P Law about 1 year ago

This snapshot doesn't show up in System -> Update now.

There is no bootable CD ISO for the development snapshots. How can I get my system up-to-date? Or back-dated to an older working release.

ISO's are useful, especially with virtualized environments.

Ken Sim wrote:

This issue is resolved with 2.4.4.a.20180712.1231 snapshot. Looks like it was an issue building zfs in the previous snapshots.

#5 Updated by Ken Sim about 1 year ago

There actually is ISO's for the development branch, its a hybrid image so if you want an iso you rename the file to .iso.

https://www.pfsense.org/snapshots/
https://twitter.com/pfsense/status/992493018857996288

#6 Updated by P Law about 1 year ago

The snapshot (still) doesn't show up under System -> Update. Anyway to force it to refresh?

Ken Sim wrote:

This issue is resolved with 2.4.4.a.20180712.1231 snapshot. Looks like it was an issue building zfs in the previous snapshots.

#7 Updated by Nick K about 1 year ago

Ken Sim wrote:

This issue is resolved with 2.4.4.a.20180712.1231 snapshot. Looks like it was an issue building zfs in the previous snapshots.

I don't believe it has unless you manually were editing the loader.conf file. I have just installed the latest snapshot and still am having the issue booting as documented above and in the prior ticket https://redmine.pfsense.org/issues/6929

#8 Updated by Ken Sim about 1 year ago

It's resolved for me and I opened the ticket, so I was letting them know its resolved for the issue I posted. You might try opening a different ticket if it's not the same issue I had.

#9 Updated by P Law about 1 year ago

I tried installing the 2.4.4.a.20180712.1231 snapshot and it fails to proceed after selecting to install with ZFS on root (one step proceeds then freezes?).

Nick K wrote:

Ken Sim wrote:

This issue is resolved with 2.4.4.a.20180712.1231 snapshot. Looks like it was an issue building zfs in the previous snapshots.

I don't believe it has unless you manually were editing the loader.conf file. I have just installed the latest snapshot and still am having the issue booting as documented above and in the prior ticket https://redmine.pfsense.org/issues/6929

#10 Updated by Ken Sim about 1 year ago

P Law wrote:

I tried installing the 2.4.4.a.20180712.1231 snapshot and it fails to proceed after selecting to install with ZFS on root (one step proceeds then freezes?).

Nick K wrote:

Ken Sim wrote:

This issue is resolved with 2.4.4.a.20180712.1231 snapshot. Looks like it was an issue building zfs in the previous snapshots.

I don't believe it has unless you manually were editing the loader.conf file. I have just installed the latest snapshot and still am having the issue booting as documented above and in the prior ticket https://redmine.pfsense.org/issues/6929

This is not the same issue, I did not have issues during the installer, just with the update image. As mentioned already you should open a ticket that reflects the issue you are having with the installer, there is a drop down for just that when creating a ticket.

#11 Updated by Nick K about 1 year ago

Ken,

I am trying to find out if you had edited the loader.conf file to add back in the ZFS loads (opensolaris_load="YES"; zfs_load="YES") after booting by using the commands outlined in #1. I did not manually edit it after I was able to boot.

#12 Updated by Ken Sim about 1 year ago

Nick K wrote:

Ken,

I am trying to find out if you had edited the loader.conf file to add back in the ZFS loads (opensolaris_load="YES"; zfs_load="YES") after booting by using the commands outlined in #1. I did not manually edit it after I was able to boot.

Haven't touched it, still the defaults from when I installed a few months back. The problem I ran into was that when they compiled the snapshot yesterday is lacked zfs support at all. This has been resolved in the most recent snapshot as mentioned above, and I am not longer having the boot issue with ZFS on root. All good here.

/boot/loader.conf

kern.cam.boot_delay=10000
kern.ipc.nmbclusters="1000000"
kern.ipc.nmbjumbop="524288"
kern.ipc.nmbjumbo9="524288"
autoboot_delay="3"
hw.usb.no_pf="1"

#13 Updated by P Law about 1 year ago

I had your issue originally, yes. I was trying to resolve it by other means (a fresh install). For example, the System -> Update page failed to see the latest snapshot update.

I added the bootloader.conf.local settings just for giggles. System -> Update wasn't reporting the latest snapshot update, but I took another try at installing it (with the bootloader settings in hopes that would help). The update process grabbed the latest update you mentioned despite the System -> Update page not seeing it.

It seems to work now.

Ken Sim wrote:

P Law wrote:

I tried installing the 2.4.4.a.20180712.1231 snapshot and it fails to proceed after selecting to install with ZFS on root (one step proceeds then freezes?).

Nick K wrote:

Ken Sim wrote:

This issue is resolved with 2.4.4.a.20180712.1231 snapshot. Looks like it was an issue building zfs in the previous snapshots.

I don't believe it has unless you manually were editing the loader.conf file. I have just installed the latest snapshot and still am having the issue booting as documented above and in the prior ticket https://redmine.pfsense.org/issues/6929

This is not the same issue, I did not have issues during the installer, just with the update image. As mentioned already you should open a ticket that reflects the issue you are having with the installer, there is a drop down for just that when creating a ticket.

#14 Updated by Ken Sim about 1 year ago

Sorry for the confusion, glad that it is working for you now. If it happens in the future (anything can happen with dev snapshots) just follow the instructions below that Raul mentioned to boot into the old kernel.

Raul Ramos wrote:

On pFsense start press 3

One at a time

load /boot/kernel.old/kernel
load /boot/kernel.old/opensolaris.ko
load /boot/kernel.old/zfs.ko
boot

#15 Updated by ROB VANHOOREN about 1 year ago

Ken Sim wrote:

The current snapshot for 2.4.4 does not allow booting from zfs on root.

issue still exists for me with 2.4.4.a.20180712.2121; booting kernel.old as an interim workaround.
(might add the ko's to loader.conf.local later today, but dealing with latest snapshots' php crankiness is more of a priority)

#16 Updated by Ken Sim about 1 year ago

ROB VANHOOREN wrote:

Ken Sim wrote:

The current snapshot for 2.4.4 does not allow booting from zfs on root.

issue still exists for me with 2.4.4.a.20180712.2121; booting kernel.old as an interim workaround.
(might add the ko's to loader.conf.local later today, but dealing with latest snapshots' php crankiness is more of a priority)

Just upgraded from 2.4.4.a.20180712.1231 to 2.4.4.a.20180713.1056 and did not have any issues at all with ZFS. So the issue has been resolved as I mentioned, you guys must be having some sort of other issues.

People should keep in mind that 2.4.4 is development and will have issues both small and large at times, I would not be running this in production at all. I just run it in a testing VM.

#17 Updated by Greg M about 1 year ago

Umm I upgraded to 2.4.4.a.20180713.1056 and it borked my machine.
Running on Hyper-v Server 2016.

Clean install is OK.

#18 Updated by Greg M about 1 year ago

As per here: https://forum.netgate.com/topic/132728/zfs-issues-built-on-wed-jul-11-16-46-22-edt-2018

I can confirm:

1. Clean install of (2.4.4-DEVELOPMENT (amd64)built on Fri Jul 13 10:56:07 EDT 2018FreeBSD 11.2-RELEASE)
2. Restore config
3. Reboot
4. Upgrade and reboot (2.4.4.a.20180713.1957)
5. Borked system zfs won`t mount

So we are not having any other issues Ken Sim mentioned but exact same thing that already happened months ago :)

#19 Updated by Michael Kellogg 12 months ago

this bit me too on bare metal hardware would be nice to have this fixed so can upgrade to get some of the php error fixes

#20 Updated by Jim Pingle 12 months ago

  • Assignee set to Renato Botelho
  • Affected Version set to 2.4.4
  • Affected Architecture set to All

There is still a problem here on current snapshots. Upgrading a VM running on ZFS to a current snapshot still fails in some cases and needs the commands listed in note 1 to proceed. Though all of the modules are present.

On the problem system, zfs_load="YES" was missing from /boot/loader.conf and adding it back in allows it to boot successfully.

#21 Updated by Renato Botelho 12 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

I detected that a static version of /boot/loader.conf was being added to pfSense-kernel package. A fix was pushed and the next round of snapshots should be OK

#22 Updated by Renato Botelho 12 months ago

  • Status changed from Feedback to Resolved

I've upgraded an old VM to most recent snapshot and loader.conf was not replaced. The bug that created this issue is now fixed

#23 Updated by Jim Pingle 12 months ago

  • Status changed from Resolved to Feedback

Latest snapshot upgrades OK from a VM that previously failed. Everything should be OK now, but additional feedback for upgrades/fresh installs would help.

#24 Updated by Jim Pingle 12 months ago

  • Status changed from Feedback to Resolved

Multiple tests and user feedback on the forum confirm this is now working properly, closing

Also available in: Atom PDF