Project

General

Profile

Bug #5260

2.3-ALPHA console option 13 upgrade hangs after installing the upgrade

Added by Phillip Davis over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Upgrade
Target version:
Start date:
10/06/2015
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.3
Affected Architecture:

Description

My test system is an APU using the 4GB nanoBSD serial image on an 8GB SD card.
I have done 2 upgrades so far. For the first one I had no serial console cable connected so was unable to see all that really happened.
For the upgrade I just did, I recorded all the serial console output.

It successfully:
1) Finds the things that need upgrading.
2) Downloads them
3) Reboots and starts the installation steps, which seem to complete fine.
4) Then:
External config loader 1.0 is now starting...
Launching the init system...pid 21 (sh), uid 0: exited on signal 11 (core dumped)

At that point it hangs - I left it for 30 minutes like that.

Power-cycle it and it boots fine with all the upgraded software, as far as I can see.

History

#1 Updated by Chris Buechler over 3 years ago

  • Category set to Upgrade
  • Target version set to 2.3
  • Affected Version set to 2.3

#2 Updated by Jim Thompson over 3 years ago

  • Assignee set to Renato Botelho

#3 Updated by Renato Botelho over 3 years ago

  • Status changed from New to Feedback

I'm guessing the error happening because the version you were running before upgrade contained the old version of pfSense-upgrade script, that was not ready for nanobsd. Can you try to gitsync it, or at least copy current pfSense-upgrade script into it and upgrade it again?

#4 Updated by Phillip Davis over 3 years ago

This is now somewhat out-of-date. Menu 13 - Upgrade from console - now does stuff to the other slice, get "Illegal number: -1", switches slices and reboots. I get whatever old version was on that other slice.
It might be better to close this, because the whole mechanism of the upgrade has changed since I logged this issue.
The "Illegal number" thing is forum https://forum.pfsense.org/index.php?topic=100603.0 - I will add to that thread with my the current symptoms.

#5 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF